cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

Plan problems

So I set up a new plan. 30 days. 500mb G3, Unlimited nationwide calling, unlimited nationwide texting. $30.00 Paid my money. Checked my account money came out. Tried to send a text but public mobile says my plan does not include texting and said to go to the website to change plan.  I went to the website and re-entered everything the same. 500mb, unlimited nationwide calling, unlimited nationwide texting $30.00. I hit enter and was told that my new $30.00 plan cost more than my old $30.00 plan and that I need to add money to my account. How do I fix this? Also, I was under the impression that the first six months were $10.00 off because I signed up online. That did not happen either.

Mayor / Maire

Re: Plan problems


@dbholte wrote:

So I set up a new plan. 30 days. 500mb G3, Unlimited nationwide calling, unlimited nationwide texting. $30.00 Paid my money. Checked my account money came out. Tried to send a text but public mobile says my plan does not include texting and said to go to the website to change plan.  I went to the website and re-entered everything the same. 500mb, unlimited nationwide calling, unlimited nationwide texting $30.00. I hit enter and was told that my new $30.00 plan cost more than my old $30.00 plan and that I need to add money to my account. How do I fix this? Also, I was under the impression that the first six months were $10.00 off because I signed up online. That did not happen either.


It might be gortched up now but try toggling the lost/stolen feature in the self-serve.

 

Log in to self-serve. Plan & Add-Ons from top menu. Lost/Stolen Phone from next menu. Suspend Service button. Log out. Wait a few minutes. Log back in and back to Lost/Stolen Phone and Resume Service this time. Log out. Restart phone.
See what happens.

 

The $10 would appear in your account as a credit. You would see it in your Available Funds. When did you sign up?

 

As for the plan change you attempted...did it seem to complete? Or did it stop you due to lack of funds? Hopefully it just stopped.

Mayor / Maire

Re: Plan problems

@dbholte

If the lost phone trick does not work as described above, you will likely need to contact moderator.  

 

By choosing another $30 plan, PM may be asking for another $30.  PM does not pro-rate plans.  

 

Send a private message to moderator through the following link :

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

Please include in the private message your phone number, your account number and PIN code.

Good Citizen / Bon Citoyen

Re: Plan problems

stopped due to lack of funds

Mayor / Maire

Re: Plan problems


@dbholte wrote:

stopped due to lack of funds


Ok. Does your overview say Active in the upper middle? What is the Available Funds balance?

So how'd it go with the lost/stolen trick?

Good Citizen / Bon Citoyen

Re: Plan problems

Not good prior to reporting it lost/stolen I could not text but data and incoming/outgoing calls worked. After reporting it stolen I can make outgoing calls but cannot get incoming calls and text still does not work.

 

Mayor / Maire

Re: Plan problems


@dbholte wrote:

Not good prior to reporting it lost/stolen I could not text but data and incoming/outgoing calls worked. After reporting it stolen I can make outgoing calls but cannot get incoming calls and text still does not work.

 


Yeah like I said...things could be gortched.

Could you post a screenshot of your overview page. Blank personal info of course.

What specific make/model phone is it?

Good Citizen / Bon Citoyen

Re: Plan problems

ZTE 828 Blurred out screenshots are beyond my ability. Account status: active

Mayor / Maire

Re: Plan problems


@dbholte wrote:

ZTE 828 Blurred out screenshots are beyond my ability. Account status: active


If you have any more model details that would help.

And Available Funds?

And which plan is shown there?

 

Edit: @dbholte: Nevermind the phone. It looks like it's ZTE Avid 828 and from what I can find I would think it should work here.

 

Man. If you want help with the service then answer the questions in a timely fashion.

 

So the last thing that I can think of is to try adding $1 to your account and restarting the phone. Sounds goofy, I know, much like the lost/stolen thing but it has worked for many.

But without you answering the questions I don't know if adding it would do anything that you had started.

Mayor / Maire

Re: Plan problems

@dbholte you could try the $1 top-up that @z10user4 mentioned, it might (or might not) work. 

 

At this point, I would strongly recommend you send the moderator team a private message (if you haven't yet) to request help, as it sounds like you experienced an activation glitch that is preventing your plan features from workng correctly.  You can learn how to reach them via private message here:  https://productioncommunity.publicmobile.ca/t5/Knowledge-Base/How-to-Get-Help/ta-p/251745


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.