cancel
Showing results for 
Search instead for 
Did you mean: 

No discounts applied

worrow
Great Neighbour / Super Voisin

I have been with public mobile for about a year, but this billing cycle in my 2 accounts, neither received the $2 autopay or the $1 referral. 

1 ACCEPTED SOLUTION

Accepted Solutions

Triguy
Mayor / Maire

Log into your account and check under rewards.  The referral award may have been removed if your referral no longer has an active account.  If you still need assistance then submit a ticket to a moderator by clicking on the question mark on bottom right corner.

View solution in original post

5 REPLIES 5

Triguy
Mayor / Maire

Log into your account and check under rewards.  The referral award may have been removed if your referral no longer has an active account.  If you still need assistance then submit a ticket to a moderator by clicking on the question mark on bottom right corner.

Jb456
Mayor / Maire

Did your plan just renew this morning?

 

When you log into your self serve account. Is there an available balance for the missing reward amount?

 

You may have lost the referral reward if person is no longer active but the auto-pay should still be available.

 

It has happened, at times, where the system charges auto-pay then applies the credit for rewards afterwards. It normally should be rewards applied first. Then available balance debited first for plan amount and any remained owed charged to the auto-pay card. However sometimes , I guess a technical glitch, it has happened that the auto-pay is charged first before the rewards are credited.

 

In your account under "make a payment" it says "view payment history" you can click that link and see what was applied and in what sequence.

 

If the money is no where to be found (meaning not in your available balance) you will have to open a ticket with moderators to look into your account 

 

Two ways to reach them.

 

1-

Simon.JPG

 

2- or via private message at link below

 

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

esjliv
Mayor / Maire

@worrow wrote:

I have been with public mobile for about a year, but this billing cycle in my 2 accounts, neither received the $2 autopay or the $1 referral. 


Hi @worrow ,

So you are saying you have been receiving the $2 autopay all along? As well, this cycle you are missing your $1 referral?

 

Was your credit card charge without the discounts?

 

If so, check under your rewards section, and click the down arrow to see if the person's phone number you referred is still listed. 

esjliv_0-1598444864917.png

 

If your credit card was charged the full amount, without your rewards deducted, contact the Moderator_Team to review via private message using this link.

Jackhyf63
Town Hero / Héro de la Ville

I suggest sending a message to the moderator team. Click this to send them a message.

worrow
Great Neighbour / Super Voisin

I never received my $2 auto pay discount on my accounts. I have a $1 referral which is for my second phone so I for sure still have that referral account lol.

 

but either way, those rewards were never applied on my account. Both accounts have been in good standing and active for approx 1 year now.