cancel
Showing results for 
Search instead for 
Did you mean: 

T911 Phone compatibility

Moid_I
Retraité / Retired
Retraité / Retired

A supported handset is required to use the T911 service. The following phones support T911:

 

APPLE

 iPhone 5S
 iPhone 5C
 iPhone 5
 iPhone 4S
 iPhone 4

 iPhone 6
 iPhone 6+

 

Alcatel 

 Idol X+

 POP Icon

 

HTC

 Desire 510 

 Desire 320a 

 

Huawei

 Ascend Y330 

 

SAMSUNG

 Galaxy S4 Mini
 Galaxy S4
 Galaxy Note
 Galaxy SIII
 Galaxy Mega
 Galaxy SIIX
 Galaxy Ace II x
 Galaxy Ace

 Galaxy S5 Active 

 Galaxy Note 4 

 Galaxy Core LTE

 Galaxy Alpha 

 Rugby 4

 

BLACKBERRY

 Q5
 Q10
 Z10
 Bold 9790
 Curve 9360
 Curve 9320
 Curve 9300

 Q20 Classic

 Passport

 

LG
 Nexus 5
 Nexus 4
 Optimus L3
 Optimus Black
 Optimus Chat
 Optimus One

 

Sonim

 XP6700

 XP7700

 

Sony Mobile

 Xperia Z3

 

Nokia 

 Lumia 520

 

For more information on where T911 is available in Canada, visit: textwith911.ca

 

3 REPLIES 3

Martin
Legend
Legend
Hello,

Your question is appropriate for the Oneplus forum, not here. T911 service is device-specific.

If you're asking if PM provides T911 service, the answer is "yes".

FYI.

Sle3man
Good Citizen / Bon Citoyen

Is this service compatible with the Oneplus One or any other Oneplus devices?

chukdefatey
Deputy Mayor / Adjoint au Maire
Those of you who are wondering what T911 is, it is used for Texting your emergency calls to 911. As far as I know (unless it recently changed) it is only for communicating with DEAF.