cancel
Showing results for 
Search instead for 
Did you mean: 

Sorry we are unable to verify your credit card information

redwheeler
Good Citizen / Bon Citoyen

I was wondering if anyone has found a solution to the following problem...

 

STEPS TO REPRODUCE:

-- Log into My Account

-- Click "Payment" 

-- Click "Manage My Card"

-- Click "Replace this credit card"

-- Fill out the information on the form

-- Hit "Register"

 

ACTUAL BEHAVIOUR:

Error message received: "Unable to process transaction. Sorry, we are unable to verify your credit card information, so this purchase could not be completed. Your credit card has not been charged."

 

EXPECTED BEHAVIOUR:

Request is processed

 

WHAT I'VE TRIED:

-- A different credit card (this works, but is not my preferred card)

-- Contacting the credit card company (they say everything's fine on their end)

-- Ensuring the address exactly matches my credit card file. I can change my credit card address online on MBNA's website, and tried the following permutations (I changed the numbers and name of the address examples):

 

1. MBNA Website = 1234 SILVER AVE STE 123

    PM Form Variations (seperated by commas) = 1234 SILVER AVE STE 123, 1234 SILVER AVE, 1234 SILVER AVE (123 in the Apt# box)

 

2. MBNA Website = 123 - 1234 SILVER AVE

    PM Form Variations (seperated by commas) = 123 - 1234 SILVER AVE, 1234 SILVER AVE (123 in the Apt# box)

 

3. MBNA Website = 1234 SILVER AVE (303 on second line)

    PM Form Variations (seperated by commas) = 1234 SILVER AVE, 1234 SILVER AVE (123 in Apt# box)

 

SOME OTHER INFORMATION:

The credit card worked upon activation for my two lines and I was charged the appropriate amount for each, but when I tried to purchase an add-on, I got the message above. So, I removed the card in an attempt to re-enter the information and now I can't get it back on the account.

 

Any ideas or success stories, I'm all ears. Thanks a lot in advance and I'll basically try anything to get this card working. For my name, city, card number, and CVV2, I have, of course, ensured that it exactly matches the card.

36 REPLIES 36


@inspyre wrote:

I am trying to update my card's expiry and cvv only, and now I am having to verify everything with Public as something triggered a problem. Really shouldn't be this hard as only the expiry and cvv changed.


Clear your browser cache/history/cookies. Close browser and open a new browser in incognito/private mode. Also, you can try a different browser.

 

Enter the credit card address “exactly” as it appears on your statement.

 

Leave the apartment field blank. If needed enter your apartment number in the street address field.

 

Note: The credit card will get locked after a few failed attempts. You will then have to contact a moderator for assistance to have it unlocked.

 

If you continue to have problems with your credit card contact a moderator:

  • Get help with your account the easy way by starting a conversation with our virtual assistant, SIMon. It’ll take you to relevant help articles, or if it’s something more urgent, it can help you submit a ticket to the Moderator Team. Click here to get started.
  • Alternatively, you can send a private message to the Moderators by clicking here. You’ll need to be logged in to your Community account for the link to work.

ruturaj
Great Neighbour / Super Voisin

I know that this is already resolved but I noticed one additional thing which is not described here so I will just add it for anyone facing a similar issue in future.

 

If you notice it clearly at the form field on the payments page, it is asking for Street Address, so Don't add your house/apt number in it, I added it thrice and didn't work, as soon as I removed it, it went through.

 

Hope it helps!

LindseyGrace
Great Neighbour / Super Voisin

I had this same issue today for the first time, was using AutoPay with the same payment method for the last 6 months, confirmed with bank no issues on their end, showed the vendor (Public Mobile) did not try to process the payment. I tried this advice but still cannot re-add the same known good payment method (that has worked elsewhere since this issue started). Are there any other known ways to resolve this issue? Thank you!

kvonrosen
Great Neighbour / Super Voisin

Hello,

 

I am about to be a new customer, but honestly I feel so disappointed about this company and I haven't even started to get services yet.

I've been trying for days to get help about activating my services, when I try to activate online I keep getting this error:

Sorry, we are unable to process your credit card request. Please ensure your credit card details are entered correctly and try again. If you continue to experience problems, please contact your credit card provider for more information.

And yes, everything is alright with the billing address, funds and card info, tried different cards and browsers. I cant believe this experience so far can only be described as frustrating and inconvenient, they have this "lunar year promo" which will expire soon and I am about to lose if I don't activate, all because of your web page problems.

I was so happy when I read all the good things and deals about this company, but so far I'm so disappointment, I am thinking to myself it was all too good to be true.

Strongly thinking about taking my business somewhere else and lose my $10 for this sim that I haven't been able to activate. Will not recommend at all if I don't get this issue resolved soon.

@kvonrosen 


Try clearing your browser cache and open a new window in incognito/private mode.

 

You can also try the live chat for activations.

https://chat.telus.com/chat/publicmobile/chat-pm.html?portal=publicmobile&language=en

 If you are using a payment card, leave the apartment/suite number in the payment information section blank.

kvonrosen
Great Neighbour / Super Voisin

Thank you for your response,

 

I did try all that already and is rather the error mentioned here or the 404 error when trying to pay.

I will contact customer chat again and see if they can help.

Thank you for the link!

Need Help? Let's chat.