cancel
Showing results for 
Search instead for 
Did you mean: 

No Service on New SIM

Iaqsa
Great Neighbour / Super Voisin

Hello, I just got a new SIM for Public Mobile and am not getting any service.  I finished the activation and my account shows the SIM as active.  However, I have no calling or data.  When attempting to call I get an error saying mobile network not available.  I have tried setting the APN, restarting, and putting the SIM in another phone with no luck.  Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions

hTideGnow
Mayor / Maire

Sound like there is a SIM provision issue if you already have tried the SIM on different phones and also confirmed account showing Active on Self-Serve.

 

Maybe it's time to open a ticket with PM and confirm any issue with the SIM provision

To open a ticket with Customer Support Agent, click on the Bubble or directly at : https://publicmobile.ca/chatbot
Enter your question in SIMon. Follow the prompts until you reach the Contact Us button,

 

If you have problems submitting a ticket, you can also send a private message to CS_Agents (but this can take longer):
https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

 

After ticket is submitted, make sure to check your Community Inbox(top right corner envelope icon) periodically for response from PM's CS Agent

 

 

View solution in original post

11 REPLIES 11


@Iaqsa wrote:

Hello, I just got a new SIM for Public Mobile and am not getting any service.  I finished the activation and my account shows the SIM as active.  However, I have no calling or data.  When attempting to call I get an error saying mobile network not available.  I have tried setting the APN, restarting, and putting the SIM in another phone with no luck.  Any ideas?


For the future, please remember that APN settings aren't related to ability to make or receive phone calls.   

 

Which models did you try the SIM card in and which carriers were y ou using them on before?  Do you know if they both have at least UMTS bands 2 and 5?

 

 

hTideGnow
Mayor / Maire

Sound like there is a SIM provision issue if you already have tried the SIM on different phones and also confirmed account showing Active on Self-Serve.

 

Maybe it's time to open a ticket with PM and confirm any issue with the SIM provision

To open a ticket with Customer Support Agent, click on the Bubble or directly at : https://publicmobile.ca/chatbot
Enter your question in SIMon. Follow the prompts until you reach the Contact Us button,

 

If you have problems submitting a ticket, you can also send a private message to CS_Agents (but this can take longer):
https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

 

After ticket is submitted, make sure to check your Community Inbox(top right corner envelope icon) periodically for response from PM's CS Agent

 

 

View solution in original post

t_p
Mayor / Maire

@Iaqsa wrote:

Hello, I just got a new SIM for Public Mobile and am not getting any service.  I finished the activation and my account shows the SIM as active.  However, I have no calling or data.  When attempting to call I get an error saying mobile network not available.  I have tried setting the APN, restarting, and putting the SIM in another phone with no luck.  Any ideas?


@Iaqsa 

Sounds like the SIM is not properly provisioned or faulty. You'll need the CS help to fix it.

But while waiting for their response, you could try to clean the SIM card contact with an isopropyl alcohol solution and reseat the card to see if it helps.

If you must buy a new card, keep the receipt and ask for a credit to your account (source: darlicious)

esjliv
Mayor / Maire

@Iaqsa wrote:

Hello, I just got a new SIM for Public Mobile and am not getting any service.  I finished the activation and my account shows the SIM as active.  However, I have no calling or data.  When attempting to call I get an error saying mobile network not available.  I have tried setting the APN, restarting, and putting the SIM in another phone with no luck.  Any ideas?


@Iaqsa   -  what other trouble shooting have you tried?

 

Try one or more of the below:

*turn off your phone, leave off for a minutes, then reboot

*removing your SIM for a few minutes, then reinserting it

*go into airplane mode for a few minutes, then going back to regular mode

*reset network settings

*Is your phone locked? Contact your previous provider to unlock it for you. You will need your imei number, dial *#06# to get it.

*Check if your phone is blacklisted here: https://www.devicecheck.ca/check-status-device-canada/

 

Have you tried your SIM card into another compatible phone to see if you have any services? This will rule out of it is a phone or account issue.

S--S
Mayor / Maire

@Iaqsa 

you can try reseat the SIM card and Make sure your phone is off before removing your SIM card,

1. power off your device

2. take out the SIM card,

3. waiting a 1 minute,

4. put it back and power on,

5. toggling airplane mode off/on,  

 

and do again Rebooting your phone,

*what is mean for Rebooting the phone means to turn off your phone and turn it back on again.

 

and you can try to reset network settings on an IPhone

Go to Settings > General > Reset > Reset Network Settings.

This also resets Wi-Fi networks and passwords,

or visit  Here link, 

 

and go Changing APN Settings On An IPhone

click Here link, 

 

How to reset network settings on an Android device
  1. Open the Settings app on your Android.
  2. Scroll to and tap either "General management" or "System," depending on what device you have.
  3. Tap either "Reset" or "Reset options."
  4. Tap the words "Reset network settings."

   or visit  Here link,

 

and go Changing APN Settings On Android device

click Here link,

 

Ensure you have the correct APN settings by visit Here link,

Select the brand and model of your phone, After doing so, you will be provided with the exact APNs required for your phone on our network.

 

or can you try manually selecting network "3G ONLY" or WCDMA only,

for iPhone visit Here link 

or Here link 

for android visit Here link ,

 

and do Rebooting your phone 

This is quick and simple,

 

and if still not fix it you Have To Submit a Ticket To Contact Customer Support Agent by  ,

Explain your issue to they can solve your issue, they are nice service Team the will help you 100%.

 

Here’s How To Contact Customer Support Agent by CS_Agent, and Submit a Ticket 

Spoiler
  • Get help with your account the easy way by starting a conversation with our virtual assistant, SIMon. It’ll take you to relevant help articles, or if it’s something more urgent, it can help you submit a ticket to Customer Support Agent by CS_Agent,Click Here link,to get started.

 

  • or you can send a private message to Customer Support Agent by CS_Agent, by Click Here link,
  • You’ll need to be logged in to your Community account for the link to work.

 

  • please include in your message,
  • your account number, 
  • your phone number,
  • your account 4 digit pin,
  • your Email address,

 

  • Customer Support Agent by CS_Agent, will Response to your inbox by private message 
  • During business hours, we strive to answer customer messages swiftly. You will often get an answer within an hour. During peak periods, you may need to wait up to 48 hours.Customer Support Agents are available:
    • Monday to Sunday: 6 AM to 10 PM EST

    Check your private message inbox (click on the envelope top right of your screen)

Good Luck..

Iaqsa
Great Neighbour / Super Voisin

Thanks everyone for the quick replies.  I think it is definitely an issue with the SIM.  Today I managed to borrow my sister's iPhone 8.  She's with Public Mobile right now.

 

I put her SIM in my phone (Xiaomi Mi 9 Lite) and it worked.  I was able to connect to the network, which confirms that my phone is compatible.  I put my SIM in her phone and there was no network connection.  Looks like a SIM issue.

S--S
Mayor / Maire

@Iaqsa wrote:

Thanks everyone for the quick replies.  I think it is definitely an issue with the SIM.  Today I managed to borrow my sister's iPhone 8.  She's with Public Mobile right now.

 

I put her SIM in my phone (Xiaomi Mi 9 Lite) and it worked.  I was able to connect to the network, which confirms that my phone is compatible.  I put my SIM in her phone and there was no network connection.  Looks like a SIM issue.


@Iaqsa 

is good to you know that your device is fine, but you to Contact Customer Support Agent by  , to them can check it out your SIM card..

 

t_p
Mayor / Maire

@Iaqsa 

As per my previous post, try to clean the SIM to see if it helps before contacting CS.

@Iaqsa yes it can be a defective sim or sim provision issue. 

 

I would start with open a ticket with PM to confirm the provisioning. If they confirm everything is fine on thieir end, then you could look into getting a replacement sim after

Need Help? Let's chat.