cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

Can't send or receive MMS

I can't seem to receive or send any MMS. Using Samsung S6 and google messenger app. Attached are my APN settings. Screenshot_20170305-115543.jpgScreenshot_20170305-115618.jpg

Tags (1)
Highlighted
Oracle

Re: Can't send or receive MMS

a) be sure cellular data is turned on.

b) do all other data connections work? 

c) do pictures go through on wifi only?


>>> ALERT: I am not a moderator. Je ne suis pas un moderateur.
Highlighted
Good Citizen / Bon Citoyen

Re: Can't send or receive MMS

a) data is turned on

b) all other data connections work

c) pictures don't go through at all. MMS doesn't utilize wifi... regardless it doesn't work with or without wifi.

Highlighted
Oracle

Re: Can't send or receive MMS

@chung01, why do you have two APNs?  The first APN combines data and MMS as noted in APN type. That may have an effect.  I have not used the google MMS app before.  Is there settings to enable it as the default app?

Highlighted
Good Citizen / Bon Citoyen

Re: Can't send or receive MMS

@will13am i had the first apn and saw on another thread someone added a second one that's specifically for MMS. That didn't work for me. Already enabled it as the default app

Highlighted
Retired Oracle / Oracle Retraité

Re: Can't send or receive MMS

Hi @chung01!

 

Try this:  1.  Delete the second APN for MMS

2.  Edit the 1st APN to include the following under APN Type: default,mms,supl

note there are no spaces after commas.  

Save changes and reboot the phone.  Test MMS.  

Highlighted
Good Citizen / Bon Citoyen

Re: Can't send or receive MMS

tried to change APN type but no bueno. Screenshot_20170305-131033.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

can anyone comment if APN protocol should be solely IPv4?

Highlighted
Oracle

Re: Can't send or receive MMS

A rediscovery that may not help from @s2scotty

 

If you have multiple APNs listed, ONLY one, the PM one, should have the APN type "default".

 

Including "mms", as in, "default,mms" makes it clear TO THE PHONE to route MMS via this APN/carrier.  IT APPEARS CRITICAL THAT there are NO SPACES between the words and the commas (e.g. "default,<space>mms" = wrong and "default,mms" = correct). A trailing space proved an issue on a phone (e.g. "default, mms<space>" = wrong and "default,mms" = correct). Like "default", only the correct and active APN should include the "mms" tag.

 

*  Name: Mobile Internet

   APN: sp.mb.com

   Proxy: Unspecified

   Port: Unspecified

   Username: Unspecified

   Password: Unspecified

   Server: Unspecified

   MMSC: http://aliasredirect.net/proxy/mb/mmsc

   MMSC proxy: 74.49.0.18

   MMS port: 80

   MCC: 302

   MNC: 220

   Authentication type: Unspecified

*  APN type: default,mms

*  APN roaming Protocol: IPv4

   Bearer: Unspecified

   MVNO type: GID

   MVNO value: 4D4F


>>> ALERT: I am not a moderator. Je ne suis pas un moderateur.
Highlighted
Mayor / Maire

Re: Can't send or receive MMS

IPv4 is correct. Your settings appear to be correct. Can you delete your secondary APN and share the lower part of the first APN's settings?
Highlighted
Good Citizen / Bon Citoyen

Re: Can't send or receive MMS

 

@sheytoon