cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Tara5
Good Citizen / Bon Citoyen

Activated my sim card, but no service.

I activated my sim card two days ago, kept my old Telus number, but still I have no service on my new public mobile service. On my phone, it doesn't even show that I have a provider. The sim card is inserted properly. What to do now? My Telus account is closed and they transferred the number to my new public mobile. I urgently need phone service, please help.


Accepted Solutions
esjliv
Mayor / Maire

Re: Activated my sim card, but no service.


@Tara5 wrote:

I activated my sim card two days ago, kept my old Telus number, but still I have no service on my new public mobile service. On my phone, it doesn't even show that I have a provider. The sim card is inserted properly. What to do now? My Telus account is closed and they transferred the number to my new public mobile. I urgently need phone service, please help.


@Tara5 

What do you mean your Telus account is closed. Are you sure it is?

 

Try one or more of the below:

*turn off your phone, leave off for a minutes, then reboot

*removing your SIM for a few minutes, then reinserting it

*go into airplane mode for a few minutes, then going back to regular mode

*Is your phone locked to Telus? Have them unlock it for you.

 

If trouble shooting is not working, submit a ticket with the moderators to check on your port.

To contact the Public Mobile Moderator_Team, there are two ways to reach them:

1 -  Faster Method - Click the bubble comment circle on the bottom right hand side of your screen, or use this link to: Get Help With SIMon the Public Mobile chatbot

 

OR

2 – Slower Method - Use this link to:

Private Message to Public Mobile Moderators (PM Customer Service Representatives)

View solution in original post


All Replies
z10user4
Mayor / Maire

Re: Activated my sim card, but no service.

 @Tara5 : Try manually scanning for networks and find Public Mobile and select it? Perhaps it was set to only Telus.

 

Edit: and restart the phone

Re: Activated my sim card, but no service.

esjliv
Mayor / Maire

Re: Activated my sim card, but no service.


@Tara5 wrote:

I activated my sim card two days ago, kept my old Telus number, but still I have no service on my new public mobile service. On my phone, it doesn't even show that I have a provider. The sim card is inserted properly. What to do now? My Telus account is closed and they transferred the number to my new public mobile. I urgently need phone service, please help.


@Tara5 

What do you mean your Telus account is closed. Are you sure it is?

 

Try one or more of the below:

*turn off your phone, leave off for a minutes, then reboot

*removing your SIM for a few minutes, then reinserting it

*go into airplane mode for a few minutes, then going back to regular mode

*Is your phone locked to Telus? Have them unlock it for you.

 

If trouble shooting is not working, submit a ticket with the moderators to check on your port.

To contact the Public Mobile Moderator_Team, there are two ways to reach them:

1 -  Faster Method - Click the bubble comment circle on the bottom right hand side of your screen, or use this link to: Get Help With SIMon the Public Mobile chatbot

 

OR

2 – Slower Method - Use this link to:

Private Message to Public Mobile Moderators (PM Customer Service Representatives)

View solution in original post

dabr
Mayor / Maire

Re: Activated my sim card, but no service.


@Tara5 wrote:

I activated my sim card two days ago, kept my old Telus number, but still I have no service on my new public mobile service. On my phone, it doesn't even show that I have a provider. The sim card is inserted properly. What to do now? My Telus account is closed and they transferred the number to my new public mobile. I urgently need phone service, please help.


@Tara5    Sounds like the port got stuck...try calling Telus porting number: 1-844-232-7678

 

Edit:  @Tara5   If it's a provisioning issue with your account then contacting moderators will be needed as noted by @computergeek541 .

 

 

Re: Activated my sim card, but no service.

@dabr 

If the Telus Mobility account got closed as a result ot the port to Public Mobile, the Publif Mobile service not working would be an account provioning issue. A Public Mobile-specific moderator would be needed.

RosieR
Mayor / Maire

Re: Activated my sim card, but no service.


@Tara5 wrote:

I activated my sim card two days ago, kept my old Telus number, but still I have no service on my new public mobile service. On my phone, it doesn't even show that I have a provider. The sim card is inserted properly. What to do now? My Telus account is closed and they transferred the number to my new public mobile. I urgently need phone service, please help.


Hi @Tara5 sorry to hear that you are having this problem.

 

Did you follow the procedures about transferring number from Telus?

 

If you wish to transfer an existing numbering from Koodo Prepaid or PC Mobile, you will need to first complete your activation with a new number, then reach out to our Moderator team here in order to transfer your existing number to Public Mobile.

 

For additional security, your previous service provider may also send an SMS text to validate the transfer. 

 

Follow the instructions in the message within 90 minutes to approve the number transfer. 

If you have missed the 90 minute window to respond, we will send you an SMS with instructions on how to re-initiate the transfer.

 

Note, that if you are transferring an existing number from TELUS Prepaid, TELUS Postpaid, or Koodo Postpaid, and have missed the 90 minute window to respond, we will automatically resend you the SMS text to validate the transfer up to 5 times between the hours of 11 AM and 8 PM ET. If those attempts are unsuccessful, we will send an SMS with instructions on how to reinitiate your number transfer request.

 

Have you done all the above?  If yes and you still don't have service, call the 

Porting Team at 1-844-232-7678 .  Please note that this number is for porting problems only and is only available during business hours.

 

Please keep us updated.  Thanks in advance.

 

RosieR

darlicious
Mayor / Maire

Re: Activated my sim card, but no service.

@Tara5 

Follow the instructions by @computergeek541 to contact the moderator team and have them reprovision the sim card/create your account. No service or sign of PUBLIC MOBILE on your phone is evidence that this is the issue ( or a complete dud of a sim card!)  Calling the telus porting department will be a waste of both your time and theirs. Once you are set up.....Welcome to public mobile!

Need Help? Let's chat.