cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
arahmanfahad
Good Citizen / Bon Citoyen

Didn’t receive reward!

Hi,

i had $10 in my account and $34 rewards. So it was supposed to charge me $5+tax from my credit card.

93E9F1D4-A515-42BB-BB92-32B3E60DDCAB.png

 but it charged me $45.20 from my card.

I didn’t receive any rewards.


Accepted Solutions
JK8
Mayor / Maire

Re: Didn’t receive reward!

@arahmanfahad 

 

To contact moderators:

 

  • Get help with your account the easy way by starting a conversation with our virtual assistant, SIMon. It’ll take you to relevant help articles, or if it’s something more urgent, it can help you submit a ticket to the Moderator Team. Click here to get started.
  • Alternatively, you can send a private message to the Moderators by clicking here. You’ll need to be logged in to your Community account for the link to work.

View solution in original post


All Replies
z10user4
Mayor / Maire

Re: Didn’t receive reward!


@arahmanfahad wrote:

Hi,

i had $10 in my account and $34 rewards. So it was supposed to charge me $5+tax from my credit card.

 

 but it charged me $45.20 from my card.

I didn’t receive any rewards.


Had you possibly used the Lost/stolen function during the last 30 days? I have had that as well. The mods will fix it.

JK8
Mayor / Maire

Re: Didn’t receive reward!

@arahmanfahad 

 

To contact moderators:

 

  • Get help with your account the easy way by starting a conversation with our virtual assistant, SIMon. It’ll take you to relevant help articles, or if it’s something more urgent, it can help you submit a ticket to the Moderator Team. Click here to get started.
  • Alternatively, you can send a private message to the Moderators by clicking here. You’ll need to be logged in to your Community account for the link to work.

View solution in original post

arahmanfahad
Good Citizen / Bon Citoyen

Re: Didn’t receive reward!

@z10user4 
Yea i used that, also swapped sim card. so that’s the problem?

kselmak
Mayor / Maire

Re: Didn’t receive reward!

Please contact moderators to take a look

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437 

 

Ps. Nice referral sum, congrats

kselmak
Mayor / Maire

Re: Didn’t receive reward!

@arahmanfahad 

Sim card shouldn't affect it, but lost/stollen will

When you immediately renew or reactivate if suspended you must pay full price, your credits should land within 24 hours

So you don't have to contact moderators only if you don't get anything within 48 hours

Tags (1)
z10user4
Mayor / Maire

Re: Didn’t receive reward!


@arahmanfahad wrote:

@z10user4 
Yea i used that, also swapped sim card. so that’s the problem?


That was my recent experience. I expect it to happen on another account in a couple days.

At least that's what the mod identified as the reason.

 

Edit: @kselmak : I think it might come back automatically if you self-suspend through your normal renewal date and then reactivate after paying full price. Maybe I'll wait it out a couple days on my other account and see.

arahmanfahad
Good Citizen / Bon Citoyen

Re: Didn’t receive reward!

@z10user4 

I used that, but my service was suspended for 1 day. Then I resumed it again.

z10user4
Mayor / Maire

Re: Didn’t receive reward!


@arahmanfahad wrote:

@z10user4 

I used that, but my service was suspended for 1 day. Then I resumed it again.


I had it off for just a few hours one day when I thought it was my turn for getting SIM-jacked. Got home and all was fine. Apparently just a bit of an outage where I was or even out of range/signal.

 

Edit: a curious aside...I went to look in my pm's for when exactly I did this and it appears my conversation with the mod has been scrubbed. Gone. Interesting.

arahmanfahad
Good Citizen / Bon Citoyen

Re: Didn’t receive reward!

Thank you everyone.

I messaged the moderator, they asked me to authorize the account and then they added the rewards as a credit to my account.

Need Help? Let's chat.