cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Citizen / Super Citoyen

Website kinda not working?

Anyone else’s plans and add ons tab from the self serve website not working? Also on the change phone number section when entering a used number and hitting the check number button, I’m getting an error on both with same message..

0FACD204-EB87-4EC3-A411-5632D18F164C.png

 


Accepted Solutions
Highlighted
Mayor / Maire

Re: Website kinda not working?

@Greg1275 

Website is more finicky and slower since last night. 

 

Might want to try in another 30-60 minutes. Or try a different web browser, clearing cache or incognito mode.  Chrome incognito works well. 

View solution in original post


All Replies
Highlighted

Re: Website kinda not working?

Most likely unplanned service update/outage.  Try again later.

 

This happens somewhat regularly.

Highlighted
Great Citizen / Super Citoyen

Re: Website kinda not working?

Ok thanks, will check back in, in a little bit.

Highlighted
Mayor / Maire

Re: Website kinda not working?

@Greg1275 

Website is more finicky and slower since last night. 

 

Might want to try in another 30-60 minutes. Or try a different web browser, clearing cache or incognito mode.  Chrome incognito works well. 

View solution in original post

Highlighted
Mayor / Maire

Re: Website kinda not working?

Try clearing your cache and use a different browser.   

Highlighted
Great Citizen / Super Citoyen

Re: Website kinda not working?

Clearing cache worked, thanks guys!

Highlighted
Great Citizen / Super Citoyen

Re: Website kinda not working?

Hi @Greg1275 , I just logged in to My Account right now to check and I received the same error message when I clicked at the Plan & Add-Ons tab. Sometimes the self-serve account page does that but it should be back up and running soon. I've only been with Public Mobile this month and it happened to me a few times where the My Account page is not working. But the Community site seems to be working all the time so that's good. Hopefully it'll work again soon.

Model Citizen / Citoyen Modèle

Re: Website kinda not working?

I've found the MyAccount webpages to be clunky and unreliable since I've joined PM. Often extremely slow to load (and therefore prone to time out). It's pretty shoddy overall, but it reflects the priority that Telus places on the brand.

Highlighted
Good Citizen / Bon Citoyen

Re: Website kinda not working?

I can't even get into my account !! Just comes up blank. I think theres something major wrong. Hope they can fix or have to look for new provider.

Highlighted
Great Citizen / Super Citoyen

Re: Website kinda not working?

Try what dunkman and triguy suggested. Clear browser cache and or try using different browser. It worked for me.