cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

I purchased both a 1Gig US data plan, and a text plan yesterday.  I am now in the US, and I show a LTE signal, connected to T-Mobile, yet have no data either up or down.

I have purchased and used the US data add on in this area on the same phone (S9) previously, without issue. 

I purchased a phone/text/data package on the same model phone (S9) for my wife yesterday as well, which is working as expected.

The only minor difference I can see, is that I have never purchased both a data pack AND a text pack together.

My Mobile Data is enabled, Flight Mode is off, Data Roaming is on, Network Mode is auto, Access point names shows as "Mobile Internet - sp.mb.com", Network operator T-Mobile (I had the same non-performance when ATT was showing as provider.

I have submitted a ticket, but any suggestions?


Accepted Solutions
Highlighted
Good Citizen / Bon Citoyen

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

Turns out the error was mine, but Public Mobile couldn't recognize the problem over the course of 20+ messages either.

 

I accidentally clicked and bought '1 Gig of Canada Data' rather than '1 gig of US data'.

My bad, so I can't blame them too hard for not being able to find out why the US data wouldn't work.  In the end, I wish they would have been able to deduce why it wouldn't work, but it was me that clued in, once I saw the option to purchase the package I thought I had was still available - knowing they disappear from the list once you've purchased them.

 

All's well that ends well, I guess.....

 

[To err is human 😊  ......... Luddite]

View solution in original post


All Replies
Highlighted
Mayor / Maire

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

Make sure you have the correct APN settings and roaming enabled.

 

https://www.publicmobile.ca/en/ns/get-help/articles/us-roaming

Highlighted
Retired Oracle / Oracle Retraité

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility


@Triguy wrote:

Make sure you have the correct APN settings and roaming enabled.

 

https://www.publicmobile.ca/en/ns/get-help/articles/us-roaming


While the APN settings do need to be correct, the settings are the same as they are for use while in Canada. I'm assuming that @WRXFiles data was working before leaving for the U.S.

Highlighted
Mayor / Maire

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

@WRXFiles reset your network settings

 

1. Open Settings>General Management>Reset
2. Tap Reset Network Settings>Tap Reset Settings
If prompted enter your pin, passcode
3. Tap Reset Settings 1 more time to confirm
4. Restart

Highlighted
Mayor / Maire

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

@WRXFiles 

It is important to restart your phone after you arrived at your destination.

If it does not work, manually switch to AT&T network.

Good luck.

Highlighted
Good Citizen / Bon Citoyen

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

Thanks for all the suggestions, I have already done all those steps to no avail.  I am messaging back and forth with Public Mobilty support, but no answer yet....  😞

Highlighted
Mayor / Maire

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

@WRXFiles enter these APN settings for Tmobile

Screenshot_20201016-121703.png

 

Highlighted
Great Citizen / Super Citoyen

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

@WRXFiles  If you dial 611 from your device is your account active? In order for US Roaming to work you PM account must be active.

Highlighted
Good Citizen / Bon Citoyen

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

Yes, I get the Public Mobile message

Highlighted
Great Neighbour / Super Voisin

Re: US Add On Purchased, Connects to T-Mobile, yet no internet accessibility

I am trying to help my daughter who is in the US and having the same problem.  Have you found a solution to this, please?

 

Need Help? Let's chat.