cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mayor / Maire

Re: The data not working in my phone

 @jerjon

Yes. Blow out the other two and add one for here.

APN is for data and MMS. Think of it as like your home wifi router that your phone needs to connect to via the cell system.

Good Citizen / Bon Citoyen

Re: The data not working in my phone

Thanks @z10user4

 

Okay, so I'll select + and type in that same info shown in screen pic I posted above,

then select it as the new "preferred APN",

then reboot phone. Correct?

I'm on WiFi now, obviously, so just don't want to get stranded  offline.

Okay so APN activates only Data service, for it....something mod help could/should have mentioned maybe!? :/

Mayor / Maire

Re: The data not working in my phone


@jerjon wrote:

Thanks @z10user4

 

Okay, so I'll select + and type in that same info shown in screen pic I posted above,

then select it as the new "preferred APN",

then reboot phone. Correct?

I'm on WiFi now, obviously, so just don't want to get stranded  offline.

Okay so APN activates only Data service, for it....something mod help could/should have mentioned maybe!? :/


All correct. This won't affect your wifi internet access. No need to go on about the mods. If it doesn't work then there are some slight edits that might get it to work. But we'll get there later.

Good Citizen / Bon Citoyen

Re: The data not working in my phone

@z10user4  thanks for your help

@

 

Okay fixed, and Data working, that was it, seemingly simple, even for a non-tech like me to do, in all this time could have been fixed, had I known.

My initial / cursory search here, didn't point me to "Public Mobile" APN needing  manually added, so hope this update will be helpful to others with same issue in future.

It bothers me is that this brand new "Public Mobile" SIM card didn't come programmed with correct APN.

Mayor / Maire

Re: The data not working in my phone


@jerjon wrote:

@z10user4  thanks for your help

@

 

Okay fixed, and Data working, that was it, seemingly simple, even for a non-tech like me to do, in all this time could have been fixed, had I known.

My initial / cursory search here, didn't point me to "Public Mobile" APN needing  manually added, so hope this update will be helpful to others with same issue in future.

It bothers me is that this brand new "Public Mobile" SIM card didn't come programmed with correct APN.


Some things get under my skin and twig me the wrong way. It still bothers me that you came in here asserting that all the settings in your phone were all good. Then you say here that you're a non-tech and that the resolution was in fact that the settings in your phone were not in fact correct.

Maybe when things aren't working for you somewhere somehow anywhere...ask yourself "but am I in fact right?".

There I feel better for saying it.

Please thank srlawren after you posted your APN screen.

Mayor / Maire

Re: The data not working in my phone


@jerjon wrote:

 

My initial / cursory search here, didn't point me to "Public Mobile" APN needing  manually added, so hope this update will be helpful to others with same issue in future.

It bothers me is that this brand new "Public Mobile" SIM card didn't come programmed with correct APN.


@jerjon many phones do NOT require this manual configuration, but with an "off brand" (sorry) like RCA, you've got to expect that they may not take the effort to pre-program in APN settings for 3rd tier and MVNO providers.  EDIT: sorry I realized this isn't very clear.  To your point, no SIM cards at all come with any APN settings on them; instead, phones come from the factory with an internal database of APN settings.  If the network you connect to is in that database, the APN is configured correctly automatically and it works.  Your phone recognized that the network is Telus, but wasn't aware of Public Mobile sub-brand (not in its database), so it did the best it could and set you up for Telus.  As we now know, that is not sufficient.  In this case, the blame falls entirely on RCA (or their OEM, whomever builds the phones for them) rather than Public Mobile.  Just so you know.

 

But knowing that some phones have quirks in how you get them up and running (while of course acknowleding that many "just work"), this is a question you should see responders asking in virtually every thread you may have found in your research:  "what brand and model phone are you using?".  I will add to my mental list that RCA phones will likely require manual APN addition.


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Good Citizen / Bon Citoyen

Re: The data not working in my phone


@srlawren wrote:

@jerjon wrote:

 

My initial / cursory search here, didn't point me to "Public Mobile" APN needing  manually added, so hope this update will be helpful to others with same issue in future.

It bothers me is that this brand new "Public Mobile" SIM card didn't come programmed with correct APN.


@jerjon many phones do NOT require this manual configuration, but with an "off brand" (sorry) like RCA, you've got to expect that they may not take the effort to pre-program in APN settings for 3rd tier and MVNO providers.  EDIT: sorry I realized this isn't very clear.  To your point, no SIM cards at all come with any APN settings on them; instead, phones come from the factory with an internal database of APN settings.  If the network you connect to is in that database, the APN is configured correctly automatically and it works.  Your phone recognized that the network is Telus, but wasn't aware of Public Mobile sub-brand (not in its database), so it did the best it could and set you up for Telus.  As we now know, that is not sufficient.  In this case, the blame falls entirely on RCA (or their OEM, whomever builds the phones for them) rather than Public Mobile.  Just so you know.

 

But knowing that some phones have quirks in how you get them up and running (while of course acknowleding that many "just work"), this is a question you should see responders asking in virtually every thread you may have found in your research:  "what brand and model phone are you using?".  I will add to my mental list that RCA phones will likely require manual


Okay, that's further clarification, thank you. In all of my past weeks of PMs for service help, None of this was offered as possible explanation, no mention of APN at all even, so to me looking through phone settings all appears correct, especially at talk & text working, and no reply saying otherwise.

It's really not clear at all except to those already know, or have had to been through the frustration.

It's working finally, so that's in the past now.

Mayor / Maire

Re: The data not working in my phone


@jerjon wrote:


Okay, that's further clarification, thank you. In all of my past weeks of PMs for service help, None of this was offered as possible explanation, no mention of APN at all even, so to me looking through phone settings all appears correct, especially at talk & text working, and no reply saying otherwise.

It's really not clear at all except to those already know, or have had to been through the frustration.

It's working finally, so that's in the past now.


@jerjon the moderators are good at troubleshooting things that involve your account.  For issues like this data not working, you're probably going to get better advice from the community.  It's unfortunate you wasted weeks interacting with the moderator team (I'm assuming that's what you mean by "PMs for service help") when the community was able to get you resolution within the same day you posted.  


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Mayor / Maire

Re: The data not working in my phone


@srlawren wrote:

@jerjon wrote:


Okay, that's further clarification, thank you. In all of my past weeks of PMs for service help, None of this was offered as possible explanation, no mention of APN at all even, so to me looking through phone settings all appears correct, especially at talk & text working, and no reply saying otherwise.

It's really not clear at all except to those already know, or have had to been through the frustration.

It's working finally, so that's in the past now.


@jerjon the moderators are good at troubleshooting things that involve your account.  For issues like this data not working, you're probably going to get better advice from the community.  It's unfortunate you wasted weeks interacting with the moderator team (I'm assuming that's what you mean by "PMs for service help") when the community was able to get you resolution within the same day you posted.  


In another thread, someone took issue with many pages of posts trying to help someone with actually an identical problem. Seemingly drawing a line on what is PM's problem and what is a problem with the phone and how much we in the community should help on non-PM problems.

Maybe PM drags their feet when it's not their problem hoping that the customer figures out the problem and therefor that it wasn't PM's problem.

Mayor / Maire

Re: The data not working in my phone

@z10user4 if the communtiy runs a full differential, these things are usually solvable.  First get the customer to confirm their account is active and their other services (talk, text) are working.  If so, we know the phone is compatible and not locked elsewhere, and the account is active.  Then get them to confirm they see a data amount in their Overview page.  If they don't and this is a new activation, they will need to contact the mods.  IF they don't and it's an existing customer, they have used all their data for the current cycle. 

 

If those things check out then we get the brand and model and see if it's on the known issues list, e.g. older iPHones need to use the unlockit site via WiFi, LG phones need a network reset and failing that a factory reset, and many ASUS and now we also know RCA models require manual APN entry.  

 

If none of those things apply then we can verify what APN the customer does have set up, ensure they haven't accidentally turned off mobile data, haven't set a data limit in their phone's settings and bumped into that, and err probably a few other things I'm forgetting.


If all of that is not the explanation, then it's time to get the moderators to check the account for issues.


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.