cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Model Citizen / Citoyen Modèle

Re: The data not working in my phone

 


@ShaylynnH wrote:

Can somebody ping the mods on this thread? I'm not sure how, but this issue seemingly needs moderator attention. Smiley Happy 


I suggest you send the moderator team a private message using this link.
Refer to the following knowledge base link for information on contacting the moderator team.

Good Citizen / Bon Citoyen

Re: The data not working in my phone

Same problem here, have confirmed is not phone settings, Data turned on, APN settings correct, Text & Talk working, SIM shows registered to same network for all three, i cycle phone couple times a day, but Still NO DATA SERVICE.

Been "trying" to get service through Mods PM (what a stupid system that is!) and still nothing.

39+ days now STILL NO DATA SERVICE.

I do not & will not recommend Public Mobile to anyone.

PS

Above link (first post) showing no longer valid.

 

Mayor / Maire

Re: The data not working in my phone

@jerjon and @m123456789 what brand and model of phone are you using?  We need this info to be able to point you in the right direction.


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Mayor / Maire

Re: The data not working in my phone


@srlawren wrote:

@jerjon and @m123456789 what brand and model of phone are you using?  We need this info to be able to point you in the right direction.


His history shows an RCA 6066 whatever that is. I can't see those numbers on the RCA US site. Maybe he has other model info. All the phones there say they would work with the likes of T-Mobile & AT&T.

 

But I wonder if jerjon could see if 3G connections would get him his data.

 

@jerjon: You've been stewing over this for 39 days and you're finally saying something here?

Good Citizen / Bon Citoyen

Re: The data not working in my phone

 Mine is a brand new RCA RLPT6066 , but is not phone issue, I've already confirmed this phone compatibility is fine, and that phone settings + APN settings are as should be.  SIM status shows the Talk, Text and Data all registered to same # , Talk and Text working since first day, but Data still not connected to network, meaning is not turned on Public Mobile side.  Started "trying" to get service help from mods last month, still not fixed, or even confirm simply that they have reset service as I've asked them multiple times to do. Supposedly was forwarded to Service dept, but Zippo reply further from them, or if even anyone trying to fix problem.Screenshot_20190211-152257.png

 

Mayor / Maire

Re: The data not working in my phone

@jerjon your APN is not right.  It needs to be sp.mb.com


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Good Citizen / Bon Citoyen

Re: The data not working in my phone

Well that's the only two choices showing on my SIM / Phone.

I didn't get any suggestion from any mods to check / how to, until I mentioned APN in PM to them.

Now magically today I suddenly get PM back about it :/

I just previously checked myself after seeing link on Telus site page of thousands of SIMs missing any APN info, and this existing Telus SP APN matched.  I've made no changes to it at all.

Mayor / Maire

Re: The data not working in my phone


@jerjon wrote:

Well that's the only two choices showing on my SIM / Phone.

I didn't get any suggestion from any mods to check / how to, until I mentioned APN in PM to them.

Now magically today I suddenly get PM back about it :/

I just previously checked myself after seeing link on Telus site page of thousands of SIMs missing any APN info, and this existing Telus SP APN matched.  I've made no changes to it at all.


APN settings. RCA is not there though. I would be curious if it's re-branded from another manufacturer.

Good Citizen / Bon Citoyen

Re: The data not working in my phone

Okay, well if you guys can help, would be appreciated, and appears vastly faster than this PM mods supposed to help system thing :/

 

No one since I started reporting problem last month, even mentioned checking "APN" settings.

 

I looked up just now "Public Mobile APN settings" and got this info.

Is this a new (+) APN profile I'm supposed to make?

Is this correct?

Screenshot_20190211-155815.png

 

 

 

It is only the Telus & Koodoo APN choices that appear on my phone, as programmed into this "Public Mobile" SIM...geez, isn't that handy!  Not! :/

The site link i came across for APN settings I found, and checked, was Telus.

 

Only today, is first I've been told or heard there should be another (3rd) choice APN, which obviously this "Public Mobile" SIM didn't come programmed with.

 

What bothers me, is that Talk & Text have been working , so the APN setting affects only the Data service?

 

I'm not a cell tech savy, so this is all new to me.

Great Neighbour / Super Voisin

Re: The data not working in my phone

Put the right VPN and restart your cell phone.