cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Good Citizen / Bon Citoyen

NEW Activation didn't occur but got charged

Went to "Mobile Shop", staff created an account, switched my current number over from Telus to PM. For some reason, somehow my number didn't switch over even though I've had my credit card billed. I can't create an account as my cell number cant be found. I do have my new PM account number and my Telus account number. If a moderator could touch base with me to correct it that would be greatly appreciated.

Good Citizen / Bon Citoyen

NEW Activation failed but credit card billed. In limbo.

Went to "Mobile Shop", staff created an account, switched my current number over from Telus to PM. For some reason, somehow my number didn't switch over even though I've had my credit card billed. I can't create an account as my cell number cant be found. I do have my new PM account number and my Telus account number. If a moderator could touch base with me to correct it that would be greatly appreciated

Tags (1)
Great Citizen / Super Citoyen

Re: NEW Activation didn't occur but got charged

It is possible that your number from TELUS didn’t port properly, or is still in the process. 

 

When you insert your Telus or PM sim, do either work?

 

If neither work, and your account is activated correctly, you may need to send the @Moderator_Team a message with your old and new account numbers, phone number, etc. It can take up to 72hours to receive a response. 

Good Citizen / Bon Citoyen

NEW Activation failed, credit card billed. In limbo...

Went to "Mobile Shop", staff created an account, switched my current number over from Telus to PM. For some reason, somehow my number didn't switch over even though I've had my credit card billed. I can't create an account as my cell number cant be found. I do have my new PM account number and my Telus account number. If a moderator could touch base with me to correct it that would be greatly appreciated

Great Citizen / Super Citoyen

Re: NEW Activation failed but credit card billed. In limbo.

Please reference my reply in the other thread. If possible, try to avoid creating exact duplicates of the same thread. 

Oracle

Re: NEW Activation failed but credit card billed. In limbo.


@lukealex121 wrote:

Please reference my reply in the other thread. If possible, try to avoid creating exact duplicates of the same thread. 


Topics now merged together. 


_____________________________________________________________________

I am not a mod. Do not send me private message with your personal info.

New Here? - Check out Knowledge Base Articles to learn more about Public Mobile.

Good Citizen / Bon Citoyen

Re: NEW Activation didn't occur but got charged

PM SIM card doesn't work, Telus does. I'll message the moderators. Thank you

Mayor / Maire

Re: NEW Activation didn't occur but got charged

@JayJitsBJJ If your Telus SIM still works then the port has not gone through yet, keep using it until it stops working, then put the PM SIM in. If the PM SIM doesn't work after Telus is disconnected then you have an incomplete port and will need to contact a moderator here: https://productioncommunity.publicmobile.ca/t5/Knowledge-Base/The-Public-Mobile-Moderator-Team/ta-p/...
Good Citizen / Bon Citoyen

Re: NEW Activation didn't occur but got charged

I've msg'd the moderators already. I did the switch earlier. There was a weird notification letting me/Mobile Shop know there was a problem with the transfer of numbers. I can't create a user account, though I have my PM account number and PM activation number. I tried to create the account by going through my email welcoming me to PM and it doesn't work. I'll see if it somehow manages to transfer overnight. I've still begun the process of messaging a moderator as I don't want to go without a phone completely.

Mayor / Maire

Re: NEW Activation didn't occur but got charged


@JayJitsBJJ wrote:

I've msg'd the moderators already. I did the switch earlier. There was a weird notification letting me/Mobile Shop know there was a problem with the transfer of numbers. I can't create a user account, though I have my PM account number and PM activation number. I tried to create the account by going through my email welcoming me to PM and it doesn't work. I'll see if it somehow manages to transfer overnight. I've still begun the process of messaging a moderator as I don't want to go without a phone completely.


When you go to create an account what is the message you are getting?