Showing results for 
Search instead for 
Did you mean: 
Mayor / Maire

Re: Data not working.

@Dankaroo, I’m referring to marking the appropriate post as the solution, rather than a random selection.

Mayor / Maire

Re: Data not working.

@stonechucker wrote:

@isabellelabelle, can you find your phone on This page and check your APN settings again?

Well, I'm back. He said.


Oracle to the rescue.


So the difference I saw with the screenshots provided by her was that the APN Type was to be blank rather than what I've more frequently seen here as a string of codes or what was suggested to her before with internet + mms.


Shouldn't APN settings be about the provider and not the phone? Why would one phone need one thing and another phone need another when they're connecting to the same provider?

Then, what's more confusing is that the only model on there was the S Duos 3 not S3. It doesn't even show the options that she listed.

So how did this work?!!! 🙂

Model Citizen / Citoyen Modèle

Re: Data not working.



When it comes to old devices or outdated version if we are talking software, companies draw a line in the sand that they do not cross because it does not equal profitability.


As standards, speed, controls and scopes change (both in device manufactured and in cellular services) this can result in legacy devices like the clients, needing to jump through hoops so to speak to work.


It's unfortunate the APN adjustment wasn't automated like most of us would be used to but alas the customer was fortunately able to get up an running by thuroughly verifying their APN settings.


You are right to say that most if not all mobile devices out there should be compatible with the service. Although it is entirely possible for the model maker to release updates to further improve older devices and their compatibility, unless they charge a fee for it and there is enough demand, they will probably never bother.

Good Citizen / Bon Citoyen

Re: Data not working.

I know this has been solved but I just wanted to add that I had issue with data not working and call and text worked.. so I followed the suggestions in this post, changed the APN setting to match what was suggested and still no data... and then, I decided delete the APN and retyped all in and now everything working... so at times, maybe thats all it needs