cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

Hi,

 

Yesterday I helped my mother in law sign up for the $15 100 minute plan which comes with 250MB data on autopay. She signed up for autopay in the store. Unfortunately, I could not get data to work for her. Any suggestions you could offer me would be greatly appreciated. I've searched and tried a number of different things.

 

- Phone is a ZTE Grand X2 / Z850 - Android. It was previously on PC Mobile as a pre-paid phone. PC Mobile pre-paid is with Bell, which uses the same network/frequencies as Telus/Public Mobile. I re-confirmed through the Public Mobile "get started"/"First check if your phone is compatible" and through another help/FAQ page third party link that the phone is compatible with both LTE and 3G frequencies.

- I have my phone on PC mobile and data worked when I put her sim in my phone.

- Initially I installed the sim card without unlocking her phone from PC Mobile. We then put the PC Mobile Sim back in called PC, received the pin to unlock the phone, swaped the sim card back to Public Mobile and was able to use the phone and make a call.

- She's able to make/receive calls without issue.

- I selected the option to enable mobile data.

- The APN was automatically populated. I confirmed it matches here and third party links provided on help pages. I reselected it, etc. https://www.publicmobile.ca/en/bc/get-help/articles/set-up-data-on-an-android-phone

- The phone was stopped multiple times, battery and sim removed/reinstalled multiple times.

- Under Mobile networks, I tried selecting the 3G/4G/Auto at various times.

 

Thanks in advance.

Highlighted
Model Citizen / Citoyen Modèle

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@jeffg997 If you check in your Mum's self service / my account does the 250 mb day at add on still show there? Ie 25/250. If it does not all the data is used up. Can you send/ recieve mms messages ? Then your apn settings are correct. 

You should then look into options to preserve data ex, downloading only on WiFi, limit which programs can use data in the background, turning data on only when required and to send/ receive mms messages. 


@jeffg997 wrote:

Hi,

 

Yesterday I helped my mother in law sign up for the $15 100 minute plan which comes with 250MB data on autopay. She signed up for autopay in the store. Unfortunately, I could not get data to work for her. Any suggestions you could offer me would be greatly appreciated. I've searched and tried a number of different things.

 

- Phone is a ZTE Grand X2 / Z850 - Android. It was previously on PC Mobile as a pre-paid phone. PC Mobile pre-paid is with Bell, which uses the same network/frequencies as Telus/Public Mobile. I re-confirmed through the Public Mobile "get started"/"First check if your phone is compatible" and through another help/FAQ page third party link that the phone is compatible with both LTE and 3G frequencies.

- I have my phone on PC mobile and data worked when I put her sim in my phone.

- Initially I installed the sim card without unlocking her phone from PC Mobile. We then put the PC Mobile Sim back in called PC, received the pin to unlock the phone, swaped the sim card back to Public Mobile and was able to use the phone and make a call.

- She's able to make/receive calls without issue.

- The APN was automatically populated. I confirmed it matches here and third party links provided on help pages. I reselected it, etc. https://www.publicmobile.ca/en/bc/get-help/articles/set-up-data-on-an-android-phone

- The phone was stopped multiple times, battery and sim removed/reinstalled multiple times.

- Under Mobile networks, I tried selecting the 3G/4G/Auto at various times.

 

Thanks in advance.


 

Highlighted
Mayor / Maire

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@jeffg997  Access her selfserve account and make sure the data counter is showing on the landing page. If not, then did you setup AutoPay for that account?  

 

If the data counter is showing then post a screenshot on the phone's APN settings.

Highlighted
Mayor / Maire

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@jeffg997 

Can you contact the moderators and give them her phone number make model and IMEI of the phone they should be able to push three settings through 

https://publicmobile.ca.ada.support/chat/ 

Mayor / Maire

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@jeffg997  In the settings you have public mobile selected in the network  settings. Post a shot of your APN settings in case your missing something. Some phones require everything set while others don't. Check that they are the same as these.

Do they match these ones?Do they match these ones?

 

Highlighted
Mayor / Maire

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@jeffg997 

Maybe try the SIM card in another to phone to help determine whether hardware set up issue versus PM service issue.  

 

If hardware set up issue, other things to try:

Network reset

Toggle airplane mode on, then off

Factory reset (back up phone first)

 

 

Highlighted
Great Neighbour / Super Voisin

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

Thanks for the replies.

@geopublic Autopay is setup and in the account I see a small amount of mobile data used, presumably from when I put her sim card in my phone.

I can't post a screenshot right now as I don't have the phone in my possession. I can try to do that tomorrow, but I definitely triple checked the APN settings.

Highlighted
Great Neighbour / Super Voisin

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@kselmak Thanks, I opened a ticket per your suggestion. I'll let you know how it makes out.

Highlighted
Mayor / Maire

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts


@jeffg997 wrote:

Thanks for the replies.

@geopublic Autopay is setup and in the account I see a small amount of mobile data used, presumably from when I put her sim card in my phone.

I can't post a screenshot right now as I don't have the phone in my possession. I can try to do that tomorrow, but I definitely triple checked the APN settings.


@jeffg997  If the APN settings are correct then remove the sim from the device wait 5 minutes and then re-insert and try again. Also, not a bad idea to do a network reset as previously suggested if data is still not working.

Highlighted
Great Neighbour / Super Voisin

Re: Data Not Working, New Sign-up - Searched/Multiple Troubleshooting Attempts

@Dunken Already tried the sim swap to another phone, it worked in my phone.

I believe I tried the network reset, airplane mode. Has anyone had a factory reset work to resolve this kind of issue? I'm very reluctant to do this as she doesn't have her contacts externally synced, etc.