cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

$25 plan but not able to connect to internet

Hello,

 

I've just switched to public mobile with a plan for data , talk and text. So far talk and text is fine. But I could not connect to the internet, like I was able to in my previous Rogers account. When I check my cellular network settings - the preferred network type is 4G, the access point names is "Telus SP" with sp.telus.com and network operator goes to searching...whenever I click on it

and when I ask it to choose automatically it tells me "registered on network". But still no internet access. 

Please let me know what else I am missing. Appreciate any advice. Thank you.

 

K


Accepted Solutions
Highlighted
Mayor / Maire

Re: $25 plan but not able to connect to internet


@Keithch wrote:

Hello,

 

I've just switched to public mobile with a plan for data , talk and text. So far talk and text is fine. But I could not connect to the internet, like I was able to in my previous Rogers account. When I check my cellular network settings - the preferred network type is 4G, the access point names is "Telus SP" with sp.telus.com and network operator goes to searching...whenever I click on it

and when I ask it to choose automatically it tells me "registered on network". But still no internet access. 

Please let me know what else I am missing. Appreciate any advice. Thank you.

 

K


HI,

If you have not done this already, try restarting your phone and resetting network settings.

Your apn should be isp.mb.com.

View solution in original post


All Replies
Highlighted
Mayor / Maire

Re: $25 plan but not able to connect to internet


@Keithch wrote:

Hello,

 

I've just switched to public mobile with a plan for data , talk and text. So far talk and text is fine. But I could not connect to the internet, like I was able to in my previous Rogers account. When I check my cellular network settings - the preferred network type is 4G, the access point names is "Telus SP" with sp.telus.com and network operator goes to searching...whenever I click on it

and when I ask it to choose automatically it tells me "registered on network". But still no internet access. 

Please let me know what else I am missing. Appreciate any advice. Thank you.

 

K


Check your APN setting on your phone.

https://apn-canada.gishan.net/en/apn/public-mobile

 

Which phone are you using?

Highlighted
Mayor / Maire

Re: $25 plan but not able to connect to internet


@Keithch wrote:

Hello,

 

I've just switched to public mobile with a plan for data , talk and text. So far talk and text is fine. But I could not connect to the internet, like I was able to in my previous Rogers account. When I check my cellular network settings - the preferred network type is 4G, the access point names is "Telus SP" with sp.telus.com and network operator goes to searching...whenever I click on it

and when I ask it to choose automatically it tells me "registered on network". But still no internet access. 

Please let me know what else I am missing. Appreciate any advice. Thank you.

 

K


HI,

If you have not done this already, try restarting your phone and resetting network settings.

Your apn should be isp.mb.com.

View solution in original post

Highlighted
Good Citizen / Bon Citoyen

Re: $25 plan but not able to connect to internet

Thank you for the link. 

I'm using a UmiDigi phone, and I applied the settings from the "andriod" link and rebooted the phone, and now I can connect to the internet and read the news there. Thanks again 🙂

Highlighted
Retired Oracle / Oracle Retraité

Re: $25 plan but not able to connect to internet

@Keithch glad you got it sorted.  I think the issue was you were on sp.telus.com.  I'm guessing you're now on sp.mb.com right?


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Highlighted
Good Citizen / Bon Citoyen

Re: $25 plan but not able to connect to internet


@krazykiwi wrote:

 

HI,

If you have not done this already, try restarting your phone and resetting network settings.

Your apn should be isp.mb.com.


Based on following the links under "What you should do after Activation" here

https://productioncommunity.publicmobile.ca/t5/Knowledge-Base/How-to-Activate/ta-p/251824

 

I believe it is sp.mb.com, maybe you typed the "i" by accident?

 

I recently activated with a LG Nexus 5X, and when I followed the instructions to check the settings, the correct APN was already there, so I didn't change any settings.  Even though my plan is for 3G data only, and it says it's connecting to LTE, it's working.

 

For the OP, also check if your phone has a setting to turn data on or off.

Need Help? Let's chat.