cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
v2k
Good Citizen / Bon Citoyen

Pixel 3 LTE+ not working

The phone is constantly vacillating between LTE and LTE+.  It ends up on LTE.

Mayor / Maire

Re: Pixel 3 LTE+ not working

@v2kIt depends where you geographic location. If your immediate tower has more capacity then you will get LTE+, if not it will drops down to LTE. However since your bandwidth is capped to 3Mbps and doesn't have VoLTE there won't be any noticeable differences.

Re: Pixel 3 LTE+ not working


@v2k wrote:

The phone is constantly vacillating between LTE and LTE+.  It ends up on LTE.


I don't believe that this is an actual problem. Some phones only show LTE+ when the data connection is actively being used.

Mayor / Maire

Re: Pixel 3 LTE+ not working

@v2k  Andriod 10 I assume? This is an issue for many right now. Not only telus but other networks. Expect an update fix in the future from google as many have been complaining to them. It's quite annoying / distracting.

Good Citizen / Bon Citoyen

Re: Pixel 3 LTE+ not working

Also, LTE+ is usually achieved by combining two bands together, ie 700 or 2100 with 2600mhz.

 

The 2600mhz band high frequency limits it's range, so you may not be 'close enough' to use it reliably. I have a Rogers BlackBerry Q10 that can only do LTE exclusively on 2600Mhz, and it really only stays on LTE in dense urban areas... (read: close to a tower)

Deputy Mayor / Adjoint au Maire

Re: Pixel 3 LTE+ not working

What's the problem exactly? I don't see anything different on my Pixel 3.

 

LTE+ indicator should only show when Carrier Aggregation (CA) is being used.