cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Model Citizen / Citoyen Modèle

Re: No service


@hairbag1 wrote:

Long shot but...try putting the sim in the second sim slot.


It's already in second slot as my previous phone used micro SIM so it's on the micro SD slot 

Model Citizen / Citoyen Modèle

Re: No service


@cellphoneuser1 wrote:

@tehowennathe wrote:

Nothing is working. Says emergency calls only. When I try to manually search for network it says no networks found


None? That's strange. It could be a broken phone. Check if phone is set to 2g by mistake; Public won't work with it set to that.  


It's set to 2G/3G/4G

Model Citizen / Citoyen Modèle

Re: No service

All I did was restart phone and then sim stopped

Good Citizen / Bon Citoyen

Re: No service

Remove sim card, try it in a different phone, if working, then buy another phone. if not contact PM. 

Model Citizen / Citoyen Modèle

Re: No service


@yanzhiqiang wrote:

Remove sim card, try it in a different phone, if working, then buy another phone. if not contact PM. 


No one I know has a phone with same sim size so can't check. Would a factory reset work?

Mayor / Maire

Re: No service


@tehowennathe wrote:

All of a sudden my phone lost service. I checked and my account is active. I turned of phone and restarted I and nothing. I took out some card and that didn't do anything. I tried everything and nothing is working. I don't know what to do. 


I know you said the account is active, but maybe try topping up your account with one dollar and then rebooting the phone.

Town Hero / Héro de la Ville

Re: No service

If you tried network reset and it didn't work, and you don't have alot to lose on your phone, a factory restore might work. Especially if the recent changes to your os caused it and you just found the trouble on your next restart?? I wouldn't rush to it though.

Mayor / Maire

Re: No service

@tehowennatheI would suggest put your SIM card into another phone and see if the problem persists. That's the quickest way to figure out the root of your issue.

Model Citizen / Citoyen Modèle

Re: No service

Everyone I know has a different sim size. May have to factory reset since it happened after a few days later after a major update from Blu getting me out of pie beta

Model Citizen / Citoyen Modèle

Re: No service

A factory reset was needed. The update that Blu sent caused the issue. It's all fixed now