cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Model Citizen / Citoyen Modèle

No service

All of a sudden my phone lost service. I checked and my account is active. I turned of phone and restarted I and nothing. I took out some card and that didn't do anything. I tried everything and nothing is working. I don't know what to do. 

Town Hero / Héro de la Ville

Re: No service

In order to better help you, we need more info about your issue:

What type of phone are you using?

What version of the OS?

Did anything happen of note? OS upgrade?

Mayor / Maire

Re: No service


@tehowennathe wrote:

All of a sudden my phone lost service. I checked and my account is active. I turned of phone and restarted I and nothing. I took out some card and that didn't do anything. I tried everything and nothing is working. I don't know what to do. 


Plug phone into AC power supply for a start.

Is anything working ?...talk / text or data ?

Model Citizen / Citoyen Modèle

Re: No service

Try toggling airplane mode on and off.

Town Hero / Héro de la Ville

Re: No service

@tehowennathe  Did you try network reset? Check APN settings to see if they changed?

Model Citizen / Citoyen Modèle

Re: No service

I am using a Blu Vivo XI+ which got out of beta for Pie on Monday. That's when I did an update to get out of beta. It was working well up until half an hour ago

Model Citizen / Citoyen Modèle

Re: No service


@hairbag1 wrote:

@tehowennathe wrote:

All of a sudden my phone lost service. I checked and my account is active. I turned of phone and restarted I and nothing. I took out some card and that didn't do anything. I tried everything and nothing is working. I don't know what to do. 


Plug phone into AC power supply for a start.

Is anything working ?...talk / text or data ?


Nothing is working. Says emergency calls only. When I try to manually search for network it says no networks found

Great Citizen / Super Citoyen

Re: No service


@tehowennathe wrote:

I am using a Blu Vivo XI+ which got out of beta for Pie on Monday. That's when I did an update to get out of beta. It was working well up until half an hour ago


Did you buy it new or used?  Did you check the national blacklist database?

Mayor / Maire

Re: No service

Long shot but...try putting the sim in the second sim slot.

Great Citizen / Super Citoyen

Re: No service


@tehowennathe wrote:

Nothing is working. Says emergency calls only. When I try to manually search for network it says no networks found


None? That's strange. It could be a broken phone. Check if phone is set to 2g by mistake; Public won't work with it set to that.