cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sherry12
Great Neighbour / Super Voisin

No service after activation

I have activated my cim card since May 24 but still haven’t yet received the signal, checked and unlocked my cell and stopped my service with previous service provider( Telus), please trouble shot 


Accepted Solutions
gblackma
Mayor / Maire

Re: No service after activation

@sherry12 your SIM didnt provision properly.  Contact the moderators amd ask them to reset it.  There are 2 ways to contact the Moderator Team:

  • Faster response- Get help with your account the easy way by starting a conversation with our virtual assistant, SIMon. It’ll take you to relevant help articles, or if it’s something more urgent, it can help you submit a ticket to the Moderator Team. Click here to get started.
  • Slower- Alternatively, you can send a private message to the Moderators by clicking here. You’ll need to be logged in to your Community account for the link to work.

Keep an eye on the envelope top right of your screen.  The mods answer will show up there.  Stay safe. 

Welcome to PM .

 

View solution in original post


All Replies
gblackma
Mayor / Maire

Re: No service after activation

@sherry12 your SIM didnt provision properly.  Contact the moderators amd ask them to reset it.  There are 2 ways to contact the Moderator Team:

  • Faster response- Get help with your account the easy way by starting a conversation with our virtual assistant, SIMon. It’ll take you to relevant help articles, or if it’s something more urgent, it can help you submit a ticket to the Moderator Team. Click here to get started.
  • Slower- Alternatively, you can send a private message to the Moderators by clicking here. You’ll need to be logged in to your Community account for the link to work.

Keep an eye on the envelope top right of your screen.  The mods answer will show up there.  Stay safe. 

Welcome to PM .

 

View solution in original post

Triguy
Mayor / Maire

Re: No service after activation

Did you port your phone# to PM ?  Did you get a text saying port was completed ?  Try reboot ING your phone. Big you still need assistance then submit a ticket by clicking on the question mark on the bottom right.

gblackma
Mayor / Maire

Re: No service after activation

While tou wait for moderator support. Wjats the make and model of your phone?  Try resetting the network settings, amd restart your phone. Wait 30 seconds and restart it. If this fails try the lost/ stolen trick. From your self service account enable the lost/ stolen feature log out, wait 5  minutes, log in and take it off. Log out and restart your phone. 20200504_182846.jpg

Welcome to PM.  Stay safe. 

Luddite
Oracle

Re: No service after activation

@sherry12  Assuming you are using the phone that worked on Telus, your account has not been activated.

If your credit card has not been charged, try the activation again: https://activate.publicmobile.ca/.

Otherwise, you must wait for the moderators.

Since you have cancelled Telus, consider the apps from Fongo or TextNow so you can call/text over wifi. They are, also, good backups for glitches.


>>> ALERT: I am not a moderator. Je ne suis pas un moderateur.
Need Help? Let's chat.