cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Good Citizen / Bon Citoyen

Cellular Data Not Working After Changing SIM Card

I recently returned from the US, where I was using a different SIM card for US service.  Since putting my Public Mobile SIM back in my iPhone I haven't been able to use cellular data.  Calls and SMS work fine.  I've confirmed the cellular network settings, reset the phone, and done a DFU reset (which wipes and loads iOS back on the phone).  The phone shows 3G and won't show LTE.  I'm able to put the same SIM card in another iPhone SE and it works fine (showing LTE).  I also put a working SIM card from Telus in this phone and it doesn't work (same issue, shows 3G and no cell data works).  Is there possibly a block or other issue with my phone on Public Mobile/Telus, or is my phone broken (the strange thing is it worked fine on LTE until I swapped back to Public Mobile when I returned to Canada)?

Deputy Mayor / Adjoint au Maire

Re: Cellular Data Not Working After Changing SIM Card

Are calls and texting working?

 

You are absolutely certain that you don't have "3G-only" set in your network settings?

 

Does 3G data work at all, at least?

 

Finally, check your APN settings: How do I set up data/APN on my smartphone?

Good Citizen / Bon Citoyen

Re: Cellular Data Not Working After Changing SIM Card

Yeah, calls and text are working fine.

 

Yeah, I've toggled LTE more than once to ensure that wasn't the issue.  LTE is turned on.

 

No, 3G doesn't work.  The phone shows 3G but no cellular data is working.  I get an alert on the phone that cellular data isn't activated when I try to use Safari (and I've confirmed that cell data is enabled for Safari).  I've confirmed that I have plenty of data left on my account (almost 4 GB).

 

Thanks, I checked my APN settings and they are correct.  I also checked for a carrier update in case that was an issue (and confirmed the carrier settings were the same as on another iPhone that works fine).  I compared all of the settings between one iPhone SE that works and my phone that doesn't and they are all the same.  It's really strange.

jp2
Deputy Mayor / Adjoint au Maire

Re: Cellular Data Not Working After Changing SIM Card

Your tests with 2 phones and different sims makes it sound like a phone issue. Unfortunately, I don't know much about iPhones but if all the settings are the same between the phones I would suspect a hardware issue. 

 

BTW thank you for posting such a great description of your issue and doing some of your own troubleshooting. It's not often we get such a good OP.

Deputy Mayor / Adjoint au Maire

Re: Cellular Data Not Working After Changing SIM Card

Hmmph.

 

When you confirmed you had data left, did you use your phone's logging/tracking or verify on PM Self-Serve?

 

Hopefully someone else can chime in with something more helpful but at this point I would send a message to the moderators to see if there's an issue with your account.

 

You can do so by clicking here and providing your email address, phone number and a description of your problem.

Good Citizen / Bon Citoyen

Re: Cellular Data Not Working After Changing SIM Card

I confirmed through the PM self-serve site.

 

Thank you for the link to message the moderators, I wasn't sure how to do that.

 

Thanks everyone for the suggestions!

Good Citizen / Bon Citoyen

Re: Cellular Data Not Working After Changing SIM Card

Thanks everyone for the suggestions.  I wanted to follow up with the problem and solution.  It turns out the profile for the other SIM card I was using (AOW) was still resident in the phone, even though it wasn't showing in the settings and had been deleted.  As a result the phone was trying to connect to AOW instead of Public Mobile.  The solution was to wipe the phone and start fresh.  I had wiped the phone but restored from a backup earlier, but the backup includes any profiles.

Great Neighbour / Super Voisin

Re: Cellular Data Not Working After Changing SIM Card

Hey there
I just want to tell and share that Even I have been facing this problem.

It started when I was in Adelaide, I got a new Sim and I only worked for calls and text. 
Though the sim was working fine (in all aspects, data, network) but only data wasn't working. 
I was getting an LTE but still not data could be accessed. The sim was tried in different phones where it worked well.
Solution: I took a whole backup and Erased my complete phone and then the phone was able to use the data from the sim.

Now after almost 4 months I've had to change my sim again from one network to another, and now the same problem has started.
The only change: I took a backup> then I did erase my phone> then the sim was able to use the data from the network.

Now when I did a "Restore from the Backup" I'm assuming the Profiles have come back again which gets me to square one!
Please guide me!!!

Deputy Mayor / Adjoint au Maire

Re: Cellular Data Not Working After Changing SIM Card


@roshan20menezes wrote:

Now when I did a "Restore from the Backup" I'm assuming the Profiles have come back again which gets me to square one!
Please guide me!!!


Is this an iPhone?  If so: Settings --> General --> Reset --> Reset Network Settings.  Enter passcode if applicable, confirm, and let the phone reboot.  You'll also need to re-connect to all  your WiFi hotspots, but at least cellular data should be restored.