cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Citizen / Super Citoyen

Unable to update Autopay card from Mastercard to AmEx

Checked with AmEx, and there is nothing blocking it on their end, but am unable to add it into the system:


Unable to Process Transaction 
Sorry, your credit card transaction was denied by your card issuer, so this purchase could not be completed. Your credit card has not been charged. Please contact your card issuer for more information.


Accepted Solutions
Highlighted
Mayor / Maire

Re: Unable to update Autopay card from Mastercard to AmEx


All Replies
Highlighted
Great Citizen / Super Citoyen

Re: Unable to update Autopay card from Mastercard to AmEx

I should add that my autopay is due in two days, so if one of the mods can assist, that would be great.

Highlighted
Mayor / Maire

Re: Unable to update Autopay card from Mastercard to AmEx

trying updating it in another browser, clearing your browser cache or try doing it in incognito mode

Highlighted
Great Citizen / Super Citoyen

Re: Unable to update Autopay card from Mastercard to AmEx

Definitely try a new browser, perhaps try doing it off of a different device. Best of luck, let us know what worked for you!
Highlighted
Great Citizen / Super Citoyen

Re: Unable to update Autopay card from Mastercard to AmEx

None of those work. I already tried that.

EDIT: I have tried it from three different devices (my phone, and two computers), and different browser variations (Chrome, Opera, Firefox).

Highlighted
Mayor / Maire

Re: Unable to update Autopay card from Mastercard to AmEx

Highlighted
Great Citizen / Super Citoyen

Re: Unable to update Autopay card from Mastercard to AmEx

If you haven't already tried it, I'm sure you have but confirm that you're filling in the fields correctly? Make sure that your address is what's on file with the credit card, same goes for your name.
Highlighted
Great Citizen / Super Citoyen

Re: Unable to update Autopay card from Mastercard to AmEx

Thanks, that address mismatch issue solved it.