cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jb456
Mayor / Maire

Payment issue - Noticed something

I had to top up a few dollars to one of the accounts I manage and received a declined message.

 

It seems like the name on the account (Not on the card set up for auto-pay) was the issue and the cause of the decline.

 

I think PM may use some personal information on the account to process transactions and not what is on the credit card. 🤔

 

First attempt to add-on money to the account resulted in this decline message.

 

Screenshot_20201110_221145.jpg

Now the only thing I had different in that account was the name to stop any unauthorized ports on the account.

 

Example.

 

Name Michael Smith.

 

I changed the name to have periods.

 

Mich.ael Sm.ith

 

I then went to edit the profile and updated the name without the periods and tried to add money again.

 

This time payment was successful.

 

So maybe some of the people that post and say their card is not working or auto-pay failed is a result of the name on the account not matching the card that was added to auto-pay?

 

If this is really one cause of declines. Then maybe we should not tell people you can put whatever name you want on the account?

 

What do you guys think? Oracle's?

 

 

 

 

 

 

Tags (1)

Accepted Solutions
mimmo
Oracle

Re: Payment issue - Noticed something

@Jb456  its not the first time i have heard of selfserve data needing to be the same as cc info, but I dont really believe its the actual case.  

 

as  for porting it seems pm implemented port protection recently, which might minimize the need for the name trick

https://www.publicmobile.ca/en/bc/get-help/articles/port-fraud-protection

 

 

View solution in original post


All Replies
z10user4
Mayor / Maire

Re: Payment issue - Noticed something

 @Jb456 : Interesting. Although I think it's likely a coincidence. I have different names on the autopay card (prepaid credit card gift card) info from my profile. But I will admit that I've never actually charged the autopay card.

I use a registered prepaid card for mobile payments of retailer apps and Google Pay. That has a different name from what the front of the card and in the account says.

JK8
Mayor / Maire

Re: Payment issue - Noticed something

@z10user4  You helped me with getting my prepaid vanilla Visa card put on my account for the autopay reward (thank you). The card failed 2x when trying to enter the information until the postal code on the credit card matched the postal code on the profile page.

z10user4
Mayor / Maire

Re: Payment issue - Noticed something


@JK8 wrote:

@z10user4  You helped me with getting my prepaid vanilla Visa card put on my account for the autopay reward (thank you). The card failed 2x when trying to enter the information until the postal code on the credit card matched the postal code on the profile page.


Interesting again. Maybe I'm all wet. Wouldn't be the first time. It would be nice if there was a way to view what is currently entered for credit card info.

geopublic
Mayor / Maire

Re: Payment issue - Noticed something

The payment processing system has a timeout issue that happens randomly. The fact that it worked after changing the name on the account is coincidence as my experience in the past is that if you keep trying to make a manual payment will eventually work.

popping
Oracle

Re: Payment issue - Noticed something


@geopublic wrote:

The payment processing system has a timeout issue that happens randomly. The fact that it worked after changing the name on the account is coincidence as my experience in the past is that if you keep trying to make a manual payment will eventually work.


If you are talking about the payment processing system at PM server, this explains why 

autopay failure (randomly) every night.

 

Jb456
Mayor / Maire

Re: Payment issue - Noticed something

@JK8  Glad you got your card working. I don't know if my post helped you as others have said it may have just been a system issue. Either or, at least your issue is solved.

 

@z10user4 @geopublic  I have this card on 3 accounts. Only the most recent account I put the periods in the name as it was at the time when all those unauthorized ports were happening. The other 2 have no issues.

 

Anyways I just changed the profile name back to the periods and tried another payment for fun.

 

It declined again🤔

 

 

 

 

darlicious
Mayor / Maire

Re: Payment issue - Noticed something

@Jb456 

Ive done manual payments in my account with credit cards that match the account exactly, then also with cards with different names or addresses or both or a kelloggs visa gift card with my cats name on it. The only time I've encountered a problem is when I forget to use secret/incognito mode.

Jb456
Mayor / Maire

Re: Payment issue - Noticed something

@darlicious  I guess it was just a coincidence then. Weird though....

mimmo
Oracle

Re: Payment issue - Noticed something

@Jb456  its not the first time i have heard of selfserve data needing to be the same as cc info, but I dont really believe its the actual case.  

 

as  for porting it seems pm implemented port protection recently, which might minimize the need for the name trick

https://www.publicmobile.ca/en/bc/get-help/articles/port-fraud-protection

 

 

View solution in original post

Need Help? Let's chat.