cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
yvonneY
Great Neighbour / Super Voisin

No Service with credit on the account

Hello,

My last payment was on September 20th for my 3 month plan, and should expire on December 18th. I changed my card number at the time and the payment went through . On October 11 my account was suspended as they wanted another 60, so I paid that too but I still have no service.  I would like this fixed please.  I have a hard time recommending this company when you have a credit and still no service. 

geopublic
Mayor / Maire

Re: No Service with credit on the account

@yvonneY  You need to submit a ticket to PM to fix your problem.

 

PMST.png

 

 

GR
Mayor / Maire

Re: No Service with credit on the account

@yvonneY  you should click here to start a conversation with Simon the chat bot and get a ticket and the moderators will get back to you to fix that problem!

https://publicmobile.ca.ada.support/chat/

popping
Oracle

Re: No Service with credit on the account


@yvonneY wrote:

Hello,

My last payment was on September 20th for my 3 month plan, and should expire on December 18th. I changed my card number at the time and the payment went through . On October 11 my account was suspended as they wanted another 60, so I paid that too but I still have no service.  I would like this fixed please.  I have a hard time recommending this company when you have a credit and still no service. 


After adding fund to your account, click the red reactivate button at top of your overview page to reactivate your account.

Dunkman
Oracle

Re: No Service with credit on the account

@yvonneY 

As you wait for moderator response, you might want to try the lost/stolen phone trick to restart/reset your plan/SIM card.  It might get your phone started.  Something is still wrong with your account billing, so you will need moderator help.

 

To report your phone  lost/stolen.  Login to your account.  Choose Plans and Add-ons tab. Then choose Lost/Stolen Phone tab.  The choose Suspend Service tab.  Logout.  Wait few minutes.  Login in and report your phone found.  Reboot phone.

 

If that does not work, manually loading $1 somtimes also restarts your plan.  

Re: No Service with credit on the account


@yvonneY wrote:

Hello,

My last payment was on September 20th for my 3 month plan, and should expire on December 18th. I changed my card number at the time and the payment went through . On October 11 my account was suspended as they wanted another 60, so I paid that too but I still have no service.  I would like this fixed please.  I have a hard time recommending this company when you have a credit and still no service. 


This once is strange because October 11th doesn't even line up with being 30 days after September 20, never mind about 90 days. The only way I could see this happening would normally be if someone change your plan. However, that wouldn't even make sense either because if even if an immediate plan change was performed (which I now you didn't do), the account couldn't be suspendd since a payment would be required to make that plan change.

 

A while back, there was an issue with the payment system assigning random and incorrect due dates to some accounts. I do wonder if this could be another instance of that. 

Need Help? Let's chat.