cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KValentine
Great Neighbour / Super Voisin

Issue: Registering for Autopay

Recently got a new credit card due to the expiry date being changed. I was signed up on Autopay beforehand, but when trying to change cards I got the following error message:

"Unable to Process Transaction 
Sorry, your credit card transaction was denied by your card issuer, so this purchase could not be completed. Your credit card has not been charged. Please contact your card issuer for more information."
 
So I tried removing my card then adding a new one to autopay, but it still gives me the same error. I called the issuing card company and they say that they're authorizing it. Anyone know how to deal with this issue?
vcadieux
Good Citizen / Bon Citoyen

Re: Issue: Registering for Autopay

This could be an issue with the billing address of your new credit card not being exactly the same as the one on your Public Mobile account.

 

You should double check that it is exactly the same as this was the cause of an issue I had in the past.

KValentine
Great Neighbour / Super Voisin

Re: Issue: Registering for Autopay

Read some of the other posts and solved it myself, here's some input just in case this affects someone else:

 

When inputting your address, if you live in an apartment and you list your address with the issuing company as: 123 - 4321 Beltway Road then you have to put that in for the address and ignore the Apartment # box following it.

 

Maple98
Great Citizen / Super Citoyen

Re: Issue: Registering for Autopay


@KValentine wrote:

Recently got a new credit card due to the expiry date being changed. I was signed up on Autopay beforehand, but when trying to change cards I got the following error message:

"Unable to Process Transaction 
Sorry, your credit card transaction was denied by your card issuer, so this purchase could not be completed. Your credit card has not been charged. Please contact your card issuer for more information."
 
So I tried removing my card then adding a new one to autopay, but it still gives me the same error. I called the issuing card company and they say that they're authorizing it. Anyone know how to deal with this issue?

This thread may have some useful tips:

https://productioncommunity.publicmobile.ca/t5/Paying-for-your-service/Unable-to-change-credit-card/...

Dunkman
Oracle

Re: Issue: Registering for Autopay

@KValentine 

The website can be finicky also.  Clearing cache, trying  a different web browser or incognito mode.  

 

If you are still having troubles, then you may need to contact moderator to help.  

Send a private message to moderator through the following link :

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

 

1vk
Good Citizen / Bon Citoyen

Re: Issue: Registering for Autopay

Did you try sign out and then reboot your phone after each change? 

Need Help? Let's chat.