cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Great Neighbour / Super Voisin

Re: I paid and still no service

Account is active. Zero balance. Nothing was changed with plan and moderators aren't very helpful especially the bot.

Model Citizen / Citoyen Modèle

Re: I paid and still no service

@Celi as I previously posted, you need to send a private message to a moderator through this link.  A human person will respond to you in aproximately 48 hours and will be able to assist you properly. 

 

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

Model Citizen / Citoyen Modèle

Re: I paid and still no service

@CeliCan you swap your SIM card with a known working phone to see if it is the problem with the phone?

 

Also have you tried the Lost / Found and $1 tricks as mentioned before? The moderators might take up to 48 hours + to get back to you.. so try other options and narrow down issues while you wait. Public Mobile users give up on support in order to save a few bucks a month.

Deputy Mayor / Adjoint au Maire

Re: I paid and still no service


@Celi wrote:

Account is active. Zero balance. Nothing was changed with plan and moderators aren't very helpful especially the bot.


I'm on day 10 of waiting for mod support. They have made me verify I am the owner twice now but other than that nothing.

I see so it worked for two months and now nothing. If possible try the SIM in another unlocked phone. It could be an antenna issue. It could also be your SIM failing (like mine might be).