cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Erroneous Payment Reminders

Today, I received a text message reminding that payment was "due soon".  Some months ago, Public Mobile stopped including a specific date in this message, but it was always received about 12 hours beofre payment was required.

 

For the messsage that I received today, it's the usual message, except that my payment is not due for more than 10 more days.  All dates in my account are fine (with the exception of Public Mobile showing an incorrect pay by date that is off by 1 day because they are now showing the new plan start date instead).

 

Did anyone else receive a payment reminder on the wrong day?

Good Citizen / Bon Citoyen

Re: Erroneous Payment Reminders

Yes, I received this message too. I didn't see a message here on the board about it so created a post too just now about it. I guess it takes some time for them to approve posts. It looks like you made yours quite a bit before me. But it wasn't showing. Interested to find out how many are getting this too. Mine happened 1 hour after I got a message about a successful referral. My due date is 12 days away. Hmm.

Re: Erroneous Payment Reminders


@vehementflame wrote:

Yes, I received this message too. I didn't see a message here on the board about it so created a post too just now about it. I guess it takes some time for them to approve posts. It looks like you made yours quite a bit before me. But it wasn't showing. .


I actually only posted about it a few minutes ago. There shouldn't be any delay for created threads and messages to show.

Good Citizen / Bon Citoyen

Re: Erroneous Payment Reminders


@computergeek541 wrote:

@vehementflame wrote:

Yes, I received this message too. I didn't see a message here on the board about it so created a post too just now about it. I guess it takes some time for them to approve posts. It looks like you made yours quite a bit before me. But it wasn't showing. .


I actually only posted about it a few minutes ago. There shouldn't be any delay for created threads and messages to show.


Ooops. Maybe I read the time of your post wrong. I thought I saw it as 53 minutes ago. Maybe it said 53 seconds ago, LOL.