cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

"Invalid SIM" after activation error

Hi folks,

I've just tried to activate my Public Mobile SIM and associate a plan.

All went well until the payment screen. Entered card details, set autopay, then clicked the Activate button - only for the browser to hang. 

Eventually gave up waiting for it to leap to life, and started the activation process again - but the initial fields now state that the SIM card is invalid; presumably it thinks it got 'activated' at the stalled payment step.

I've tried going through a couple of different browser types, and chrome's incognito mode, with no results.

Annoyingly, I haven't received any activation success messages from Public either, so I'm assuming it's failed at that end; it looks like I don't have an account, and can't log in. 

 

I suspect I'll have to wait a few hours and try again, then PM the mods, but thought I'd see if anoyone had any other bright ideas before resigning myself to another day without cellular data.

 

Thanks!

Tags (3)

Accepted Solutions
Highlighted
Mayor / Maire

Re: "Invalid SIM" after activation error

@CroakerBC  Try the PM sim in your phone. Does it connect to PM? If yes, click here to register your selfserve account. 
 If you can't connect try again later.

View solution in original post


All Replies
Highlighted
Mayor / Maire

Re: "Invalid SIM" after activation error

Sorry to hear that this happened to you @CroakerBC . Was as your credit card charged? If it was, contact a moderator and explain your situation . Click on the green questionmark in the white circle at the bottom right of your screen . This connects to the autobot Simon . Type moderator and follow the prompts to get to one.  

Can you log into your account? If no, refresh your browser, go to incognito/private mode in your browser and redo the process. Welcome to PM .


@CroakerBC wrote:

Hi folks,

I've just tried to activate my Public Mobile SIM and associate a plan.

All went well until the payment screen. Entered card details, set autopay, then clicked the Activate button - only for the browser to hang. 

Eventually gave up waiting for it to leap to life, and started the activation process again - but the initial fields now state that the SIM card is invalid; presumably it thinks it got 'activated' at the stalled payment step.

I've tried going through a couple of different browser types, and chrome's incognito mode, with no results.

Annoyingly, I haven't received any activation success messages from Public either, so I'm assuming it's failed at that end; it looks like I don't have an account, and can't log in. 

 

I suspect I'll have to wait a few hours and try again, then PM the mods, but thought I'd see if anoyone had any other bright ideas before resigning myself to another day without cellular data.

 

Thanks!


 

Highlighted
Mayor / Maire

Re: "Invalid SIM" after activation error

@CroakerBC  Try the PM sim in your phone. Does it connect to PM? If yes, click here to register your selfserve account. 
 If you can't connect try again later.

View solution in original post

Highlighted
Great Neighbour / Super Voisin

Re: "Invalid SIM" after activation error

Thanks folks.

I hadn't considered putting the SIM in-device and then using that number to start the self-serve. 

Looks like it works, though right now I have no idea if promos and referall codes were correctly applied.

But I have a working phone, and that's what I needed - thanks!

Highlighted
Mayor / Maire

Re: "Invalid SIM" after activation error

@CroakerBC  you are welcome.  Glad we could help you . Welcome to PM. 


@CroakerBC wrote:

Thanks folks.

I hadn't considered putting the SIM in-device and then using that number to start the self-serve. 

Looks like it works, though right now I have no idea if promos and referall codes were correctly applied.

But I have a working phone, and that's what I needed - thanks!


 

Highlighted
Mayor / Maire

Re: "Invalid SIM" after activation error


@CroakerBC wrote:

Thanks folks.

I hadn't considered putting the SIM in-device and then using that number to start the self-serve. 

Looks like it works, though right now I have no idea if promos and referall codes were correctly applied.

But I have a working phone, and that's what I needed - thanks!


1.  You will get the referral credit within 72 hours after activation  Usually next morning.

2.  You should already received the $2 autopay as available fund in your account.

3.  The promo $5 or $10 credit will be added to your account as available fund within 30 days after activation.  YMMV My experience with my past actiation, you may get your credit 2 weeks after activataion.  YMMV