cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

data not working after paying the $10 top up

Hi, I'm used to have data as an add on for within CA. 2 days back I paid CAD10 online for the 200MB data add on but until now its not picking up the signal. My APN is already set to public mobile ( sp.mb.com). When i try using the data it says  YOU ARE UNABLE TO ACCESS THE WEB with a whole list of reasons which dont make sense like my plan has expired or there is fraud  or that I am in the USA. This doesnt make any sense. Appreciate some urgent help

Mayor / Maire

Re: data not working after paying the $10 top up

@dreamboats198  - When you log into your self serve portal, does your add-on show in the Plan and Add-ons section?  By any chance is there $10 in your account balance that you cannot otherwise explain?  Are you sure you performed the 2 step procedure for purchasing add-ons?

 

Mayor / Maire

Re: data not working after paying the $10 top up


@dreamboats198 wrote:

Hi, I'm used to have data as an add on for within CA. 2 days back I paid CAD10 online for the 200MB data add on but until now its not picking up the signal. My APN is already set to public mobile ( sp.mb.com). When i try using the data it says  YOU ARE UNABLE TO ACCESS THE WEB with a whole list of reasons which dont make sense like my plan has expired or there is fraud  or that I am in the USA. This doesnt make any sense. Appreciate some urgent help


@dreamboats198 To contact Public Mobile click here. The link sends you to the private message function and adds the moderator team as recipient for a private message. You just have to enter a title and text in the body of the message describing the problem and post. The message will be received by the moderator team and they will respond to it. You will receive the response in your private message inbox.

Moderator Hours: Monday-Friday 8 am(Eastern) to 12 am(Eastern) and Saturday, and Sunday from 8 am(Eastern) to 10 pm(Eastern).

Deputy Mayor / Adjoint au Maire

Re: data not working after paying the $10 top up


@dreamboats198 wrote:

Hi, I'm used to have data as an add on for within CA. 2 days back I paid CAD10 online for the 200MB data add on but until now its not picking up the signal. My APN is already set to public mobile ( sp.mb.com). When i try using the data it says  YOU ARE UNABLE TO ACCESS THE WEB with a whole list of reasons which dont make sense like my plan has expired or there is fraud  or that I am in the USA. This doesnt make any sense. Appreciate some urgent help


Is your base plan active?  Add-on can't used if the account is suspended.  I am guessing and that's why I ask.

Good Citizen / Bon Citoyen

Re: data not working after paying the $10 top up

they are having some extreme data issues right now. they wont' even reply to my messages about my plan is supposed to have 8.5 gigs of data but didn't even give me any. , switching tommorow to chatr or lucky if they don't get back to me. 

Good Citizen / Bon Citoyen

Re: data not working after paying the $10 top up

I'm considering the same-used to have Chatr earlier and was much easier to speak to someone for tech support. Probably worth paying the extra buck

Good Citizen / Bon Citoyen

Re: data not working after paying the $10 top up

thanks for your reply. Now that you mentioned it- yes I have a 10$ credit which probably wasnt there earlier. But the $10 I paid PM ( already charged on my card) was for urgent data on my phone not to sit as a credit. 

Any remedies?

Good Citizen / Bon Citoyen

Re: data not working after paying the $10 top up

Thanks, I reached out to them yesterday, still awaiting a concrete answer

Good Citizen / Bon Citoyen

Re: data not working after paying the $10 top up

Yes it is active and the 10 bucks have been charged on my card. Still no luck with accessing data

Re: data not working after paying the $10 top up

@dreamboats198, did you complete the addon process?  it's two step.

 

Once to add the money, then go back to apply the addon.