cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Great Neighbour / Super Voisin

Re: changed my plan now phone doesn't work

thanks alot I'll try this

Town Hero / Héro de la Ville

Re: changed my plan now phone doesn't work


@kainer84 wrote:

thanks alot I'll try this


Good Luck, it may take 48-72 hrs for a reply as they are very busy. If you would like to carry on in the meantime we may be able to help you understand everything a little bit better.

Highlighted
Mayor / Maire

Re: changed my plan now phone doesn't work

@kainer84, seeing the info in your payment history would helps help you.  Wé'd still like to ensure that this is the actual problem.

Good Citizen / Bon Citoyen

Re: changed my plan now phone doesn't work

First thing to try when you have such problems is always to restart your device

Deputy Mayor / Adjoint au Maire

Re: changed my plan now phone doesn't work

Just for clarity - I am trying to gather a pattern

 

What plan were you on and cost?
What plan did you move to and cost?
Is autopay enabled?
Did you use the option to 'Change at next renewal' or 'Change now'?

 

I recently opened a new temp plan that I used for my wife in the US. Now that we are back, I have 'downgraded' this plan to the $10 plan for next renewal. I am curious to see what happens.

 

Side note - opening a new PM plan strickly for USA Roaming was cheaper (and easier) than using a local SIM and much cheaper than Koodo roaming.  

 

Great Citizen / Super Citoyen

Re: changed my plan now phone doesn't work

Restart your phone. If doesn't work it's possible it's a glitch in the PM system. If that's the case contact a mod and they wi help. I had that issue few months back and mods really helped out. 

Model Citizen / Citoyen Modèle

Re: changed my plan now phone doesn't work

@kainer84

I'd also recommend restarting your device and see if that helps. If it's already passed the 48 hours or so since you changed your plan and you have also restarted your phone, you might want to contact a Moderator for some further assistance. I don't know if resetting your network settings might also help.

Here's a link on how to do so if you need some guidance.

https://productioncommunity.publicmobile.ca/t5/Knowledge-Base/The-Public-Mobile-Moderator-Team/ta-p/...