cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Mayor / Maire

Re: Sim invalid


@cellphoneuser1 wrote:

@darlicious wrote:

 

@ClaudiaaFortin  If as you say on your very first try you got the invalid sim message I think it is very likely you have a bad SIM card. Where did you purchase the SIM card? I know Wal-Mart had recieved a bad batch.


Bad batch? A defect would normally be a manufacturing defect. That won't make activation say invalid sim. If it's a bad causing that, that means Public forgot to add them to the database.


@cellphoneuser1  "Bad batch" There was a customer who recieved this message after many posts of how to clear your browser etc....it was clarified by the OP this was the message that was recieved on the first attempt at activation. I advised him to go back to Wal-Mart for a refund or exchange. While there it took three different "new sims" to get one to activate. The sims were all defective coming from a "bad batch" they had recieved. If I used a poor choice of words to describe a defective SIM card it still remains true that the invalid sim message can be recieved on the first try at activation meaning the SIM card has previously been used or is defective possibly from a "bad batch" of SIM cards.

Highlighted
Great Neighbour / Super Voisin

Re: Sim invalid

Hi,

 

if you tried all other tricks (including shutting down phone, removin and re-inserting SIM) mentionned by others and still no sucess, you can go to Wal-mart or any suggested retail store (https://www.publicmobile.ca/en/on/store-locator).  I went to Wal-mart today and they gave me the SIM free if I let the clerk do the transfer for me !...  Better check if this "promotion" is available in all stores.

 

good luck!

 

Highlighted
Great Neighbour / Super Voisin

Re: Sim invalid

We had a similar issues just now with my daughter's new account.  We tried a few times and looked through the community posts, which all said to contact a moderator.

 

I sent a pm, however, in the meantime I was bored so I kept scrolling through.  I found the comment by gblackma about using 'incognito mode' (which I seriously thought was ludicrous... but I was bored..).  Incognito mode worked like a charm.  Thank you, gblackma.

 

I would also like to say THANK YOU to the PM Moderators.  They have been extremely helpful and quick to respond.