cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

Royal Screwup

Hey there,

 

So, I just tried seting up my account and followed all the steps correctly to port my number over fom Virgin Mobile.  The problem I encountered - I hit an auto fill to quickly enter my number and an alternative one, but somehow through the auto fill process it totally entered my number (I'm trying to port) incorrectly. It swapped numbers from both my phone and my alternative phone number (kept area code and first three digits the same and swapped out the last four digits with the alternative number).  I didn't catch it until after the payment screen was done.  I didn't hit the FINISH button, but I tried to go back to fix the number and I couldn't get anywhere.  The page asked me to start again, but it was too late as the SIM was already activated with a number that is not mine and now I'm not sure how to correct the issue.  Is there anyway to fix this problem, other than ordering a new SIM card and tying again???  I really want to keep my old number I'm trying to port!

It was supposed to be an easy setup!!  Any help would greatly be appreciated.

Model Citizen / Citoyen Modèle

Re: Royal Screwup

Mayor / Maire

Re: Royal Screwup


@WollR77 wrote:

Hey there,

 

So, I just tried seting up my account and followed all the steps correctly to port my number over fom Virgin Mobile.  The problem I encountered - I hit an auto fill to quickly enter my number and an alternative one, but somehow through the auto fill process it totally entered my number (I'm trying to port) incorrectly. It swapped numbers from both my phone and my alternative phone number (kept area code and first three digits the same and swapped out the last four digits with the alternative number).  I didn't catch it until after the payment screen was done.  I didn't hit the FINISH button, but I tried to go back to fix the number and I couldn't get anywhere.  The page asked me to start again, but it was too late as the SIM was already activated with a number that is not mine and now I'm not sure how to correct the issue.  Is there anyway to fix this problem, other than ordering a new SIM card and tying again???  I really want to keep my old number I'm trying to port!

It was supposed to be an easy setup!!  Any help would greatly be appreciated.


@WollR77  No need to buy a new sim. Since the number is not yours the port will fail. Access toy selfserve account and select the change number option. Select a temp number from the Public pool. If the number change is successful then select change number again and setup the port of you old number.

 

If that doesn't work message the moderators and explain what happened include all the correct porting info and they will setup the port for you.

 

To contact Public Mobile click here. The link  sends you to the private message function and adds the moderator team as recipient for a private message. You just have to enter a title and text in the body of the message describing the problem and post. The message will be received by the moderator team and they will respond to it. You will receive the response in your private message inbox.

Moderators are available: M-F from 8 AM to midnight Eastern time and S-S from 8 AM to 10 PM Eastern time.

Note: Moderator Hours are subject to change, but you can always find the current times here

Please note that account verification may be required when contacting the Moderator Team 

 

Great Neighbour / Super Voisin

Re: Royal Screwup

Thanks!  Just was able to finally change my number over.  For some reason I could not see the "change my phone number" icon on my desktop login account.  I used my phone to access account and changed over to the new number (the correct one) with the port.  It said it was "succesful".  I will wait and see now.  Appreciating he reply!

Great Citizen / Super Citoyen

Re: Royal Screwup

I had a similar problem and the mods were able to sort it out.  Then I couldn't receive calls.  I restored my phone to factory settings and everything has worked perfectly ever  since.  I'm very happy with Public after a bit of a rough start.