cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Good Citizen / Bon Citoyen

Re: [Issue Resolved] Payment and activation bug

I've set up a new account/attempting to activate a SIM with a plan and it is telling me to contact PM. I actually ported a number from another provider and just want to pay, but it won't allow me. It's the same method that I use for my regular plan. Any help would be much appreciated. 

Re: [Issue Resolved] Payment and activation bug


@3mom wrote:

I've set up a new account/attempting to activate a SIM with a plan and it is telling me to contact PM. I actually ported a number from another provider and just want to pay, but it won't allow me. It's the same method that I use for my regular plan. Any help would be much appreciated. 


I've moved your message into a separate thread.  This is so that you can get more focused answers and so that your issue doesn't get lost in multiple replies from people who aren't discussing the issuing that you're having.

 

What's the exact error message that you're seeing?

 

Mayor / Maire

Re: [Issue Resolved] Payment and activation bug


@3mom wrote:

I've set up a new account/attempting to activate a SIM with a plan and it is telling me to contact PM. I actually ported a number from another provider and just want to pay, but it won't allow me. It's the same method that I use for my regular plan. Any help would be much appreciated. 


Ensure that you use a separate email address for each account. You can use same credit card though.

Can you do a screen snip of the message you get ?

Mayor / Maire

Re: [Issue Resolved] Payment and activation bug

@3mom  sounds like this is an issue with your phone number port request. As a workaround you can pick a temp PM number and once your account has been activated and your selfserve account has been setup you can then setup you phone number port.

Great Citizen / Super Citoyen

Re: [Issue Resolved] Payment and activation bug


@3mom wrote:

I've set up a new account/attempting to activate a SIM with a plan and it is telling me to contact PM. I actually ported a number from another provider and just want to pay, but it won't allow me. It's the same method that I use for my regular plan. Any help would be much appreciated. 


@3mom  Just trying to gleam info out of your post to the problem youre experiencing. Is the issue the payment being accepted? Or is it the porting attempt? If it is a koodo or pc mobile prepaid account you need to choose a temporary number as those types of accounts require a moderators assistance to complete the port for you. That means after you complete the activation successfully you will have to complete a ticket via simon (?) and submit it.

Good Citizen / Bon Citoyen

Re: [Issue Resolved] Payment and activation bug

@darlicious it's a number from FIDO. The issue is the payment. It won't accept it & then tells me to contact Public Mobile. 

Great Citizen / Super Citoyen

Re: [Issue Resolved] Payment and activation bug

@3mom  What is the payment method you are attempting? I've had some issues with visa/debit lately. As well if you have attempted more than 3 or 4 times in can lock you out. So you could try again today.  Are you attempting to pay the same amount as your plan? Are you close to your own renewal date? As per usual you are clearing your browser and in secret mode before you start. Has your billing address on your statement changed? Are you close to the expiry date?

Good Citizen / Bon Citoyen

Re: [Issue Resolved] Payment and activation bug

@darlicious I'm using the same Visa Debit that I use for my plan. I want to activate a new sim for a new plan, but I'm still receiving the same response that activation has failed and I need to contact PM.

Mayor / Maire

Re: [Issue Resolved] Payment and activation bug


@3mom wrote:

@darlicious I'm using the same Visa Debit that I use for my plan. I want to activate a new sim for a new plan, but I'm still receiving the same response that activation has failed and I need to contact PM.


To contact PM, use SIMon chatbot to submit a ticket to Moderators.

Go to https://publicmobile.ca.ada.support/chat/ and enter "submit a ticket" and "contact us" to get started. Response time can vary from a few hours up to 2 days.