cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
grutledge
Great Neighbour / Super Voisin

Please fix your website!!!

I heard about public mobile from a website reviewing phone plans.  I was quite excited when I went to the web site and found it nicely laid out and easy to understand.  I decided to get my son's new phone set up with one of their plans.  I ordered a sim card online, but then realized that if I wanted to take advantage of their $10 off per month for the first 6 months I needed to get the plan activated by dec 31.  So I drove to London drugs, bought another sim card and then proceeded to activate the sim card. 

 

This is where things went bad.  I first tried on my iphone, which involves filling in several forms etc.  But when I got to the end I needed to check a box and hit continue to finish. This was not possible since the continue button was under some other text and it was not possible to select it (hmm seems bad when you cannot use a phone to activate a mobile phone account).  I then tried using chrome on my mac book pro.  Spent more time filling in forms etc and this time I could actually hit the continue button.  Filled in more stuff, selected a plan, filled in credit card info etc and hit activate - start the spinning.  this just never finished even after waiting an hour.  Finally quit that and tried in firefox.  Filled in the same forms for a third time and hit activate. This time it said my credit card was denied (which it never is).  Hit activate again and it worked.  So after 4 hours of pain and frustration, we finally got it to work, but guess what, the $10 dollars off a month for the first 6 months was not applied.

 

Someone please end this painful experience. If there is a moderator listening, please fix this situation and apply my $10 a month discount like you are advertising. 

 

If there is a public mobile web developer listening, please fix your web interface so it works on all platforms and browsers. 

 

For any new public mobile customers, please beware, this is not a smooth experience.


Accepted Solutions
RobertQc
Mayor / Maire

Re: Please fix your website!!!


@grutledge wrote:

I heard about public mobile from a website reviewing phone plans.  I was quite excited when I went to the web site and found it nicely laid out and easy to understand.  I decided to get my son's new phone set up with one of their plans.  I ordered a sim card online, but then realized that if I wanted to take advantage of their $10 off per month for the first 6 months I needed to get the plan activated by dec 31.  So I drove to London drugs, bought another sim card and then proceeded to activate the sim card. 

 

This is where things went bad.  I first tried on my iphone, which involves filling in several forms etc.  But when I got to the end I needed to check a box and hit continue to finish. This was not possible since the continue button was under some other text and it was not possible to select it (hmm seems bad when you cannot use a phone to activate a mobile phone account).  I then tried using chrome on my mac book pro.  Spent more time filling in forms etc and this time I could actually hit the continue button.  Filled in more stuff, selected a plan, filled in credit card info etc and hit activate - start the spinning.  this just never finished even after waiting an hour.  Finally quit that and tried in firefox.  Filled in the same forms for a third time and hit activate. This time it said my credit card was denied (which it never is).  Hit activate again and it worked.  So after 4 hours of pain and frustration, we finally got it to work, but guess what, the $10 dollars off a month for the first 6 months was not applied.

 

Someone please end this painful experience. If there is a moderator listening, please fix this situation and apply my $10 a month discount like you are advertising. 

 

If there is a public mobile web developer listening, please fix your web interface so it works on all platforms and browsers. 

 

For any new public mobile customers, please beware, this is not a smooth experience.


@grutledgeThe self-serve system has its issues, but in the end everything works.

 

As for your credit. Did you read the advertisment?

 

https://productioncommunity.publicmobile.ca/t5/Announcements/Activate-any-30-mo-plan-online-and-get-...

 

"The first credit will be applied to all eligible accounts within 30 days of activation. Credits 2-6 will be applied prior to each renewal date."

 

 

View solution in original post


All Replies
RobertQc
Mayor / Maire

Re: Please fix your website!!!


@grutledge wrote:

I heard about public mobile from a website reviewing phone plans.  I was quite excited when I went to the web site and found it nicely laid out and easy to understand.  I decided to get my son's new phone set up with one of their plans.  I ordered a sim card online, but then realized that if I wanted to take advantage of their $10 off per month for the first 6 months I needed to get the plan activated by dec 31.  So I drove to London drugs, bought another sim card and then proceeded to activate the sim card. 

 

This is where things went bad.  I first tried on my iphone, which involves filling in several forms etc.  But when I got to the end I needed to check a box and hit continue to finish. This was not possible since the continue button was under some other text and it was not possible to select it (hmm seems bad when you cannot use a phone to activate a mobile phone account).  I then tried using chrome on my mac book pro.  Spent more time filling in forms etc and this time I could actually hit the continue button.  Filled in more stuff, selected a plan, filled in credit card info etc and hit activate - start the spinning.  this just never finished even after waiting an hour.  Finally quit that and tried in firefox.  Filled in the same forms for a third time and hit activate. This time it said my credit card was denied (which it never is).  Hit activate again and it worked.  So after 4 hours of pain and frustration, we finally got it to work, but guess what, the $10 dollars off a month for the first 6 months was not applied.

 

Someone please end this painful experience. If there is a moderator listening, please fix this situation and apply my $10 a month discount like you are advertising. 

 

If there is a public mobile web developer listening, please fix your web interface so it works on all platforms and browsers. 

 

For any new public mobile customers, please beware, this is not a smooth experience.


@grutledgeThe self-serve system has its issues, but in the end everything works.

 

As for your credit. Did you read the advertisment?

 

https://productioncommunity.publicmobile.ca/t5/Announcements/Activate-any-30-mo-plan-online-and-get-...

 

"The first credit will be applied to all eligible accounts within 30 days of activation. Credits 2-6 will be applied prior to each renewal date."

 

 

View solution in original post

Dunkgirl
Deputy Mayor / Adjoint au Maire

Re: Please fix your website!!!

@grutledgeIf you just activated it takes up to 30 days to get your first credit its very clear in the terms of service. https://productioncommunity.publicmobile.ca/t5/Announcements/Activate-any-30-mo-plan-online-and-get-...

grutledge
Great Neighbour / Super Voisin

Re: Please fix your website!!!

Thanks for the quick response and clarification.  Very impressive.  I’m afraid your comment that “in the end everything works” is simply not true.  It did not work at all for 2 different attempts with browsers that are very common.  The only reason it worked for me in the end is that I was willing (begrudgingly) to try several different things.  Most customers will not be so willing.Website really needs some work in terms of better error feedback and guidance when things go wrong.  I didn’t even mention several other issues that came up.  Hopefully work is being done on that.

Need Help? Let's chat.