cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

Huge Problem Activating with PM

Hey All,

 

I bought a SIM with the intention of porting my number from TELUS. I went through the entire activation process, including entering my credit card details and submitting, whereafter I got an error that said "oops". The PM SIM now reads as invalid when I try the process again, the charge made it to my credit card and the PM SIM card does not work when inserted in my phone (Unregistered SIM). When I try to sign in to Self Serve, it is unssuccessful and has no history of my email address.

 

This all happened on Friday, so I messaged the mods and decided to wait patiently, however as of Monday morning, my TELUS SIM is no longer working and my cell number is out of service. 

 

I am at a loss right now and regretting my decision to try to switch to PM. I'm not sure who to call or what to do. I appreciate any help or guidance!

 

Thanks!


Accepted Solutions
Highlighted
Model Citizen / Citoyen Modèle

Re: Huge Problem Activating with PM


@mlsteam wrote:

Thanks for the suggestion, I did, however as my number is now out of service I cannot receive the 6 character code required to create the account.

 

Even if I didn't successfully set up the account, shouldn't the PM SIM card work if it activated successfully?

 

I'm mostly worried about losing my number at this point. I think I will temporarily reactivate with Telus until I hear back from the mods. 


So, what ends up happened is, you have a semi-ported status with PM.

PM is having some issue fully ported your number.

 

But one thing you don't have to worry is you will not lose your number.

I was worring about that, but after the port is done, you should be fine.

 

You can ask Telus if you number can be ported back, but I am not sure if that would worsen the situation, since you are trying to port over an unfinished port.

View solution in original post


All Replies
Highlighted
Model Citizen / Citoyen Modèle

Re: Huge Problem Activating with PM


@mlsteam wrote:

Hey All,

 

I bought a SIM with the intention of porting my number from TELUS. I went through the entire activation process, including entering my credit card details and submitting, whereafter I got an error that said "oops". The PM SIM now reads as invalid when I try the process again, the charge made it to my credit card and the PM SIM card does not work when inserted in my phone (Unregistered SIM). When I try to sign in to Self Serve, it is unssuccessful and has no history of my email address.

 

This all happened on Friday, so I messaged the mods and decided to wait patiently, however as of Monday morning, my TELUS SIM is no longer working and my cell number is out of service. 

 

I am at a loss right now and regretting my decision to try to switch to PM. I'm not sure who to call or what to do. I appreciate any help or guidance!

 

Thanks!


What you can do now, is to wait. 

For now, the turnaround time is about 2-3 days for the mod to reply.

You are not the only one having the issue. 

There have been mulitple reports, including myself, experiencing the same issue.

 

If you can't wait, what you can do is to buy a temp SIM card from a different carrier with a different number and make through your days. This is what I am doing right now.

 

Once again, sorry to see this, but trust me, there are quite a few reports since end of December already.

Highlighted
Mayor / Maire

Re: Huge Problem Activating with PM

Since registering have you gone to My Account and selected Create An Account to create your self-serve account? It's independant from your community account.

Highlighted
Great Neighbour / Super Voisin

Re: Huge Problem Activating with PM

Thanks for the suggestion, I did, however as my number is now out of service I cannot receive the 6 character code required to create the account.

 

Even if I didn't successfully set up the account, shouldn't the PM SIM card work if it activated successfully?

 

I'm mostly worried about losing my number at this point. I think I will temporarily reactivate with Telus until I hear back from the mods. 

Highlighted
Model Citizen / Citoyen Modèle

Re: Huge Problem Activating with PM


@mlsteam wrote:

Thanks for the suggestion, I did, however as my number is now out of service I cannot receive the 6 character code required to create the account.

 

Even if I didn't successfully set up the account, shouldn't the PM SIM card work if it activated successfully?

 

I'm mostly worried about losing my number at this point. I think I will temporarily reactivate with Telus until I hear back from the mods. 


So, what ends up happened is, you have a semi-ported status with PM.

PM is having some issue fully ported your number.

 

But one thing you don't have to worry is you will not lose your number.

I was worring about that, but after the port is done, you should be fine.

 

You can ask Telus if you number can be ported back, but I am not sure if that would worsen the situation, since you are trying to port over an unfinished port.

View solution in original post

Highlighted
Great Neighbour / Super Voisin

Re: Huge Problem Activating with PM

Ok, as long as my number will be safe. So I may just have to wait with no cell number for a few days?

Highlighted
Model Citizen / Citoyen Modèle

Re: Huge Problem Activating with PM

Right, that's what I have experienced.

Highlighted
Good Citizen / Bon Citoyen

Re: Huge Problem Activating with PM

If you have access to wifi there are many free apps that give you a free number. You can  Call aand get calls  and text from them and in most of Canada get a local number.  If your allowed to post the name of the apps. I can tell you the name of it. 

Highlighted
Good Citizen / Bon Citoyen

Re: Huge Problem Activating with PM

Exact same issue and waiting on a resolution. Hoping it resolves quickly for all of us in this boat.

 

day 7 and I’m working now! Cheers and hope this is the only hiccup

Highlighted
Good Citizen / Bon Citoyen

Re: Huge Problem Activating with PM

I have a similar situation however, the 2-3 day response for a reply from the Mod Team isn't anywhere near correct. I activated my PM account and SIM on December 31st. Telus informed me that the number was ported on January 2nd. I have sent 5 private messages over 5 days and still don't have any acknowledgement or a reply from the Mod Team. My friends tell me they also get a "number not in service" message when trying to phone me. This is extremely poor service. PM needs to adress this lack of customer service immediately! @Moderator_Team

Tags (1)