cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

First call goes straight to Voicemail, second is ringing...

Hi,

 

I've got a problem with my number (it was a new number from PM, not a port). Everytime somebody calls me (I've tried different providers, even landline) the first time call goes straight to voicemail then if re-dialed the phone rings normally. If somebody calls me after a while the same problem repeats, first call voicemail, second call ringing.

 

Signal is not an issue (tried on various locations, even full bar), the phone is iPhone 6s so that should be fine as well.

 

Any idea what could be wrong?

 

Thanks,

 

Dejan


Accepted Solutions
Highlighted
Mayor / Maire

Re: First call goes straight to Voicemail, second is ringing...

Thats some weird stuff, dont think its anything from the community that can be cleared up.

 

Send a private message to the moderators, probably somethign technical going on in the background.

 

http://productioncommunity.publicmobile.ca/t5/Knowledge-Base/Contacting-our-Community-Moderators/ta-...

View solution in original post


All Replies
Highlighted
Mayor / Maire

Re: First call goes straight to Voicemail, second is ringing...

Thats some weird stuff, dont think its anything from the community that can be cleared up.

 

Send a private message to the moderators, probably somethign technical going on in the background.

 

http://productioncommunity.publicmobile.ca/t5/Knowledge-Base/Contacting-our-Community-Moderators/ta-...

View solution in original post

Highlighted
Model Citizen / Citoyen Modèle

Re: First call goes straight to Voicemail, second is ringing...

Have you checked your phone settings?.  I am not familier with iPhones but I know there are phones (android) where you have options not to recieved calls i.e. do not disturb mode and if the same person calls in few minutes then your phone would ring.

 

I would also reboot your phone and if still having the same problem then for sure contact one of mod and they will be happy to check this for you.

 

Good luck 

Highlighted
Great Neighbour / Super Voisin

Re: First call goes straight to Voicemail, second is ringing...

Thanks, I've tried all that and had already contacted the mods, hopefully they will be able to find a solution.

Highlighted
Great Neighbour / Super Voisin

Re: First call goes straight to Voicemail, second is ringing...

Did you find a solution to this? I'm having the same issue.
Highlighted
Mayor / Maire

Re: First call goes straight to Voicemail, second is ringing...

@Paulm@dejansl you could try either of the following to narrow down if this is a phone/settings issue or a network/account issue:

 

1) Put your SIM card in another phone.  Borrow one from a friend or family member for a few mins to try it.  Just make sure that it is compatible as per willmyphonework.net, and that it's either an unlocked phone or it came from Telus or Koodo, and put your SIM in and try calling your number from aother line.  If the behaviour continues, it's an account or network issue; if the issue goes away, it's your phone settings.

 

OR

 

2) Put someone else's SIM card in your phone.  Borrow a friend's SIM for a few mins to try.  If your phone is unlocked and compabile with PM, a friend's SIM from any Canadian provider should work fine I beleive.  If your phone is still locked to Telus or Koodo (which is fine for use with PM), then you'd need to borrow a SIM from a friend on PM, Telus, or Koodo.  Put their card in your phone and try calling their number from another line.  If you get the same behaviour you were getting with your SIM, then it's a phone/setings issue; if the calls work fine on your phone with their SIM card, then it's an account/network issue.


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Highlighted

Re: First call goes straight to Voicemail, second is ringing...

I remember having a similar problem at Mobilicity and the probelm ended up being the specific phone I was using. 

 

At the time, I was using a POS (and I don't mean Point of Sale) HTC Panache.  The phone had a very serious software bug that HTC never bothered to address.  On that phone, badly programmed software made it so that when the first person called me after the phone was in an extended sleep period, it would disconnect me from the network for about 30 seconds.  This was especially true after waking up in the morning, and it didn't matter if the my first incoming phone call of the day was at 5am or 11am.   But if the person tried to call a minute later, the call would come through okay every time, as soon as the phone finished reconnecting to the network.  The only way to solve the problem in that case was to flash a different radio file. Doing that didn't completelly solve the problem as the network disconnection would still occur but it did make it so that reconnection would only take about 10 seconds, meaning that no calls would be missed.

 

My point is that badly coded custom ROMs or sometimes even bad software from the manufacturer can sometimes cause all types of funny network connection issues.  It wouldn't a bad idea to borrow another device to see if this issue still occurs when using different phone hardware.

Highlighted
Mayor / Maire

Re: First call goes straight to Voicemail, second is ringing...

@computergeek541 was that phone running Lollipop? It sounds similar to an issue in my old 1st gen Moto X after upgrading from KitKat to Lollipop. I never made the connection to extended sleep as it would happen seemingly randomly though the day that it would disconnect for 30 seconds or so at a time but I suppose it could have been sleeping in retrospect!

>>> ALERT: I am not a moderator. For account or activation assistance, please click here.
Highlighted

Re: First call goes straight to Voicemail, second is ringing...


@srlawren wrote:
@computergeek541 was that phone running Lollipop? It sounds similar to an issue in my old 1st gen Moto X after upgrading from KitKat to Lollipop. I never made the connection to extended sleep as it would happen seemingly randomly though the day that it would disconnect for 30 seconds or so at a time but I suppose it could have been sleeping in retrospect!

The HTC Panache was much, much older than a phone that would have been running Lollipop.  The Panache was a 2011 model running Gingerbread. 

 

It would be fine during the day as long as I didn't go to sleep and not use my phone.  But as soon as the phone sat there unused for more than about 5 hours (that's a guess), it would do that network disconnection nonsense each and every day as soon as the first person of that day was to try calling me.  However, if I actually just woke the phone up by pressing the power button, there was still signal; it was the actual act of receiving a phone call that would cause the network disconnect.

 

At first I though it was a Mobilicity issue, but after I switched to Wind, the problem remained.  The problem was even more obvious after switching to Wind because they send you a missed call text message.  

 

Once I was able to successfully replicate the problem, I started doing silly work arounds like calling my cell phone from my home phone as soon as I woke up each day.  I even went as far as timing the disconnection and figuring out that it took about 45 seconds to reconnect each time.  The disconnection itself wasn't really a problem, but the way it took so long to reconnect meant the the person calling me would get sent straight to voicemail.  After I did some rooting and flashing, I managed to decrease the reconnection time to about 10 seconds.  When I tested, that was quick enough of a reconnection that the phone was at least ring when called (although the start of the first ring was delayed).

 

As soon as I switched to a different model phone, the deep sleep mode network disconnection problem vanished.

Highlighted
Great Neighbour / Super Voisin

Re: First call goes straight to Voicemail, second is ringing...

For me on my iPhone X, this was caused by the phone being in "Do Not Disturb" mode. Once I turned that OFF, I was getting calls on first attempt.