cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

Disappointing Start. :(

Well, it's been a rather disappointing start with Public Mobile and I'm not sure what else to do other than sit back and wait for a Mod to help, but perhaps one of you can help me?

 

2 SIM cards, 2 issues.

Card A: seemed to have no issues. Account set up fine. Put it in the iPhone and it states "No Service"

- the iPhone is unlocked, every setting has been reset multiple times, powered off & one, phone erased, another Bell SIM card checked in the phone (it works just fine) initial carrier settings were updated... everything I could think of. What next?

 

Card B: Can't get past the account/setup SIM page as the card number shows as "invalid".

- I've checked the community for answers, deleted my cache and cookies, tried incognito, tried from another browser, another computer, nothing works.

 

I'm feeling buyers remorse at the moment and I'm really bummed out. Any advice here? Thanks. 

Oracle

Re: Disappointing Start. :(

@hjdup, if seems like you have what you can.  Account problems can only be dealt with by the moderator team.  Since you have messaged them already, the only thing you can do is sit back and let the do their thing and fix the accounts.  

Deputy Mayor / Adjoint au Maire

Re: Disappointing Start. :(


Can't get past the account/setup SIM page as the card number shows as "invalid".

There should not be a connection with this issue. But did you use a different address for your second SIM activation?

Good Citizen / Bon Citoyen

Re: Disappointing Start. :(

It wouldn't even let me put in an address. It just says invalid SIM as soon as I type it in. If I do try to submit the page it just resets, highlights the SIM number in red and states "invalid". I need to fix the issue before I can even proceed.

Good Citizen / Bon Citoyen

Re: Disappointing Start. :(

Yeah, that's what I thought. I'll try to be patient but it hasn't been a great first impression so far. Hopefully, it'll turn around when I hear back from them. Was just hoping someone might make a suggestion I haven't thought of or wasn't aware of.

Town Hero / Héro de la Ville

Re: Disappointing Start. :(



@hjdup

Only one SIM card can be linked to a PM Account.  I'm guessing this is "Card A".

 

The iPhone has been erased/reset, and restarted (with the PM SIM installed).

 

You should see an "Activation Lock" screen which will prompt you to enter your Apple ID.  An iOS security feature meant to prevent a thief from just stealing an iPhone and popping in another SIM.

Entering the correct Apple ID should make everything else "just work", it'll autodetect and autoconfigure everything for Public Mobile.

Entering an incorrect Apple ID won't let you proceed past this point.  Too many incorrect guesses will make the phone impose an increasingly large delay between guesses, and past a certain threshold the iPhone will "brick" itself - appear to work but lockout everyone - at least until it's "fixed" by an authorized Apple "genius".  This "feature" is always a risk when buying used iPhones because only Apple can make such phones work again, and they'll only deal with the original owner holding the original receipt.

 

Are you certain your iPhone is not carrier-locked?

And that it's not blacklisted?

You can check the IMEI at several online databases like this.

 

I suspect it's a problem on PM's end which PM will fix within hours or a day at most.  Sometimes their accounting systems and their technical systems aren't completely in sync, lol.  Try starting up the iPhone again tomorrow.

Good Citizen / Bon Citoyen

Re: Disappointing Start. :(

Yes, I know only 1 card per account. I tried to set up a second and received the "invalid SIM" even prior to putting in any further account info (address, email, cc, etc). So I tried the solutions I did to no avail. It's the SIM itself it seems and not my browser.

 

Apple ID was entered with no issues. The phone set up just fine. Carrier shows "public mobile" but states "no service" anyway (yes, I have coverage in my area). Phone is not blacklisted, nor does it have an activation lock. It was not linked to another account. I called Rogers and they unlocked both phones for me, and yes the IMEI was checked prior to all of this. 

 

I let the phone sit overnight, powered it back on... still no service. I reset the network settings once more and still... nothing. Smiley Sad

Town Hero / Héro de la Ville

Re: Disappointing Start. :(

Maybe try restarting the phone again.  Complete shutdown/restart, with the SIM installed?

Good Citizen / Bon Citoyen

Re: Disappointing Start. :(

The moderators got back to me. Everything is working smoothly now. Thanks!

Model Citizen / Citoyen Modèle

Re: Disappointing Start. :(

Initial post shows a week ago

I hope it wasn't that long 

 

Can you share what the issue was?