Showing results for 
Search instead for 
Did you mean: 
Great Neighbour / Super Voisin

Could not activate Cellular Network



So I've gone through the steps here:


I also did a search in the community but I'm still not having any luck.


The only thing I see on my iphone 6 is Personal Hotspot. When I reset the cellular data network it changes to I've tried as well as Anytime I change the cellular settings I restart my phone.


It does says Public Mobile 3G in the top left corner. I've also looked for Settings > General > Profiles but couldn't find anything.


Does anyone have any suggestions? Thanks.

Mayor / Maire

Re: Could not activate Cellular Network

Did you tried network reset or factory reset also since iPhone doesn't have much setting option available make sure LTE toggle is on and do a network reset by going setting general then reset then network reset
** I am not a Mod, please do not include any private info in a private message to me.**
Mayor / Maire

Re: Could not activate Cellular Network

I'll go with the old IT solution, try a hard reset, replacing your sim, or even trying you sim in another phone, see if it changes anything.


THough with an iphone 6 shouldn't make a difference.

Model Citizen / Citoyen Modèle

Re: Could not activate Cellular Network

Hey @andreamccabe


Usually you just need to pop your sim in your iPhone and you are good to go!

Your iPhone should install Carrier Profile update automatically, you don't need to do anything. But sometime your phone setting is preventing you from connecting the internet.


Here are some simple troubleshooting.

1) Make sure you delete all profile you installed (especially if you come from Freedom/Wind). You can do so at Settings > General > Profiles. (If you don't see it you are good to go)


2) (It is likely your case) Check Settings > General > About > Carrier, make sure you are on "Public Mobile 28.0".

Older iOS verison will not allow you to update Carrier Profile automatically, you may wish to upgrade to iOS 10. You can also use online APN profile installer (


3) Check Settings > Cellular > Cellular Data is on. 


4) Restart your phone. Remove your SIM card and place back in again.


5) Reset network settings by tapping Settings > General > Reset > Reset Network Settings.


I do not recommend resetting your iPhone in the first place since it is not necessary in many cases. Check this out:


Hope it helps! If you still have question, just ask the community here!

Great Neighbour / Super Voisin

Re: Could not activate Cellular Network

Thanks @echf for the suggestions. Updating my phone to the latest IOS fixed the problem and it's now showing Public Mobile as the Carrier under Settings > General > About > Carrier.

Great Neighbour / Super Voisin

Re: Could not activate Cellular Network

Same problem happened with me.I just restart my phone and work great

Great Neighbour / Super Voisin

Re: Could not activate Cellular Network

I tried all this and still am getting the same error. Everything lookds fine and the phone is showing that I am on LTE. Any other suggestions?