cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

Activating Sim Card Issue

Hi:

 

I just activated 4 phones today for my family.  All with different SIMS and emails.

 

The last one went through the entire activation process and then I got a 404 timeout screen.

I checked my credit card and it was charged.  The phone shows No Service and I am unable to log into the account that was created.

If I retry the SIM it now says its invalid.  What can I do?

Thanks


Accepted Solutions
Highlighted
Retired Oracle / Oracle Retraité

Re: Activating Sim Card Issue


@dq wrote:

Hi:

 

I just activated 4 phones today for my family.  All with different SIMS and emails.

 

The last one went through the entire activation process and then I got a 404 timeout screen.

I checked my credit card and it was charged.  The phone shows No Service and I am unable to log into the account that was created.

If I retry the SIM it now says its invalid.  What can I do?

Thanks


Check if your credit card was charged. If it hasn't been charged, wait 50 minutes and then try activating that last one again. if the charge did show up for that last account, open a ticket to moderators by going to https://publicmobile.ca.ada.support/chat .

View solution in original post


All Replies
Highlighted
Retired Oracle / Oracle Retraité

Re: Activating Sim Card Issue


@dq wrote:

Hi:

 

I just activated 4 phones today for my family.  All with different SIMS and emails.

 

The last one went through the entire activation process and then I got a 404 timeout screen.

I checked my credit card and it was charged.  The phone shows No Service and I am unable to log into the account that was created.

If I retry the SIM it now says its invalid.  What can I do?

Thanks


Check if your credit card was charged. If it hasn't been charged, wait 50 minutes and then try activating that last one again. if the charge did show up for that last account, open a ticket to moderators by going to https://publicmobile.ca.ada.support/chat .

View solution in original post

Highlighted
Mayor / Maire

Re: Activating Sim Card Issue

 


@computergeek541 wrote:

@dq wrote:

Hi:

 

I just activated 4 phones today for my family.  All with different SIMS and emails.

 

The last one went through the entire activation process and then I got a 404 timeout screen.

I checked my credit card and it was charged.  The phone shows No Service and I am unable to log into the account that was created.

If I retry the SIM it now says its invalid.  What can I do?

Thanks


Check if your credit card was charged. If it hasn't been charged, wait 50 minutes and then try activating that last one again. if the charge did show up for that last account, open a ticket to moderators by going to https://publicmboile.ca.ada.support/chat .


Hi @computergeek541 , you may want to fix that link to SIMon as it won't work

https://publicmobile.ca.ada.support/chat/

Highlighted
Retired Oracle / Oracle Retraité

Re: Activating Sim Card Issue


@LovesToPM wrote:

 



Hi @computergeek541 , you may want to fix that link to SIMon as it won't work

https://publicmobile.ca.ada.support/chat/


Thanks. It was mistyped.

Highlighted
Mayor / Maire

Re: Activating Sim Card Issue

Hi @dq 

 

Welcome to Public Mobile!

 

Did you use the same credit card for all 4 activations? If so, you may have triggered Public Mobile's anti-fraud policy. I believe the limit is 2 to 3 usages of the same card. As computergeek541 mentioned, check your credit card to see how many charges went through.

 

If there are 3 charges, retry the activation but wait 50 minutes after your last attempt (as the SIM number may still be locked by your previous session). And please try to use a different card if you can.

 

p.s. I hope you were able to use your own referral code for all those activations.

Highlighted
Great Neighbour / Super Voisin

Re: Activating Sim Card Issue

Hi:

 

So of the four phones, one was my wife's and she used her own credit card.  It was good.  I set up my own (it was good) and two more for each daughter.  The first daughter's was good.  The last one I set up had the issue.  I put mine and each daughters on my credit card.  All three were charged, but the last daughter's wasn't activated (no account with Public and no service).  The sim says invalid (even after waiting).  I'm assuming if they charged my credit card the account must have been created.  Not sure what to do. Thanks.

Highlighted
Mayor / Maire

Re: Activating Sim Card Issue

@dq 

 

Send a private message to Moderators explaining this issue: https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

Only they can fix it for you. You may send them your SIM number, the email that was used to activate and any other relevant info.

 

They will likely respond some time tomorrow as it is late now. Please keep an eye on your message inbox to look for their reply.

Highlighted
Great Neighbour / Super Voisin

Re: Activating Sim Card Issue

Thanks.  I will try that.

Highlighted
Retired Oracle / Oracle Retraité
Need Help? Let's chat.