cancel
Showing results for 
Search instead for 
Did you mean: 

The dreaded "Generic Error" when trying to activateHi

shartomjam
Town Hero / Héro de la Ville

I am trying to activate a SIm and account for my daughter.  I am using Chrome incognito and got the dreaded "generic error" after the final screen and tried it twice.  I made sure all info from credit card was correct (matching statement).  I have messaged the Mod Team.  Any other ideas?

6 REPLIES 6

lemew07
Great Citizen / Super Citoyen

@shartomjam wrote:

I am trying to activate a SIm and account for my daughter.  I am using Chrome incognito and got the dreaded "generic error" after the final screen and tried it twice.  I made sure all info from credit card was correct (matching statement).  I have messaged the Mod Team.  Any other ideas?


Looks like there may be a system glitch you have company in your trouble boat lol. Another customer failed at the activation stage. PM the mods good luck Lemew

popping
Oracle
Oracle

@shartomjam wrote:

I am trying to activate a SIm and account for my daughter.  I am using Chrome incognito and got the dreaded "generic error" after the final screen and tried it twice.  I made sure all info from credit card was correct (matching statement).  I have messaged the Mod Team.  Any other ideas?


After getting the generic error, you need to close your brower.  Wait a few minute and do the activation again.  

Tav
Model Citizen / Citoyen Modèle

Mine is giving the same generic error after processing my old providers info to port my number. It says to close out all browsers and wait 50 minutes.

 

Seems like activate.publicmobile.ca is timing out.

 

I'm awaiting a response from the mods to see if its me or if there are issues. 

Nocturno
Great Neighbour / Super Voisin

Same error, thought it was just me and got a SIM card replacement.

 

When I tried with the new SIM, it says my old number that I'm trying to port over cannot be ported anymore. Will be messaging the Mods.

shartomjam
Town Hero / Héro de la Ville

@popping wrote:

@shartomjam wrote:

I am trying to activate a SIm and account for my daughter.  I am using Chrome incognito and got the dreaded "generic error" after the final screen and tried it twice.  I made sure all info from credit card was correct (matching statement).  I have messaged the Mod Team.  Any other ideas?


After getting the generic error, you need to close your brower.  Wait a few minute and do the activation again.  


Unfortunately, her credit card was charged on one of the attempts so we have to go through the mods.  They have already responded and her issue should be fixed.  

Tav
Model Citizen / Citoyen Modèle

Same on mine as well.

 

Everything is working except for incoming calls (I guess also voicemail can't work because of that) and I cannot yet login to my account.