Showing results for 
Search instead for 
Did you mean: 

Service in the Sudbury, Ontario Area

Good Citizen / Bon Citoyen

Just wo wondering if anyone else in the Sudbury, Ontario area (particularly North of Sudbury on the highway 144 corridor) is having issues this morning? My phones show "not registered " this morning. 





Mayor / Maire



There is no official service status issue according to Telus outage site


Did you try to reseat your sim (power off, take sim out for a minute, then put it back and power up)

Or if you have another phone around, try to put your sim card in the 2nd phone and test it that way


Good Citizen / Bon Citoyen

I have 2 phones using public mobile and they have both been without service (call, text, data) for just over 2 days now. I’ve tried restarting the phones and removing the SIM cards but haven’t had any success gaining service. Let me know if you find anything out. cheers

@pjgagne  are you in Sudbury, too?  did you login to My Account and confirm if the account status is Active?
And did you test your phone from another location as well?


since you have 2 phones with PM, please also try to put SIM 1 from phone 1 into Phone 2 and vice versa.  This might for a re-provisioning of the sim card /account and that could resolve the problem


But of course, if that does not work, open ticket with PM Support and let them know

1. If you have access to My account: At

Start by typing "Submit a ticket", then click "Contact Us", Then click "Other", then click "Click here to submit a ticket ↗" 

2. If you don't have access to My Account or have trouble with Chatbot: Private message CS Agent at:

**Monitor your Community inbox (envelope icon on the top right) after the ticket is opened.  CS Agent will reply you there



Good Citizen / Bon Citoyen

I am in Northern Ontario near the Kenora, ON area. My account is active and I have tried using my SIM card in another phone and from multiple locations.I suppose I will have to open a ticket then. Thanks for the help

@pjgagne   If it is northern Ontario as well, it could be related.    


and changing Preferred network to 3G Only did not help?


If you have not done so, open a ticket with PM.  Let us know how it turns out


Mayor / Maire

@pjgagne Have you ever had this issue before?

Good Citizen / Bon Citoyen

In the 2.5 years I’ve been with public mobile, I’ve never had this issue.

Good Citizen / Bon Citoyen

Just to provide an update. Two phones affected today by this. The issue resolved itself about 1800 hours this afternoon.  Guessing local tower was down, or a service issue in Sudbury. Either way, resolved now.


@Bandsaw   thanks for the update, happy to see you back.


@pjgagne  any luck with you ?  try to reboot your phone and see