cancel
Showing results for 
Search instead for 
Did you mean: 

My US roaming add-on is not working.

mhayes
Great Neighbour / Super Voisin

I have bought two US roaming add-ons. I purchased the first one in Canada, a few days before my trip. I guess it started immediately because I only had use of it for the first few days after I entered the US. Isn't there a way to delay activation? Do I have to purchase this add-on the same day of entry into the US in order to benefit from a full 10 days of service?

 


Since I ran out of Roaming service before the end of my stay, I purchased a second add-on. I purchased it two days ago and I am still without service. 

 


I tried to get help for this problem yesterday. I am still waiting for assistance. Ticket reference number: 130582-715

1 ACCEPTED SOLUTION

Accepted Solutions

Roaming add-ons are always effective immediately after purchase. As for why the second one isn't working, you'll need to wait for a reoly from a custimer support agent.

View solution in original post

12 REPLIES 12

Roaming add-ons are always effective immediately after purchase. As for why the second one isn't working, you'll need to wait for a reoly from a custimer support agent.

mhayes
Great Neighbour / Super Voisin

Ok, so you do have to buy the add-on the day you travel. Thank you!

 

softech
Mayor / Maire

@mhayes wrote:

 


I tried to get help for this problem yesterday. I am still waiting for assistance. Ticket reference number: 130582-715


@mhayes   Message CS agent again with this reference number.  

 https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437


**Monitor your Community inbox (envelope icon on the top right) after the ticket is opened. CS Agent will reply you there

 

mhayes
Great Neighbour / Super Voisin

Yes, I did that this morning. Thank you.

riker_huang
Great Neighbour / Super Voisin

Same problem here, purchased the US roaming add-on an hour ago but my account doesn't show roaming plan has been added.

 

 

Hi, logoff from My Account now 

Then use Incongito mode and check again.

If you don't see it, check Payment history page

 

If you see it, reboot your phone once and then make sure you connect to TMOBILE or AT&T .  of you have Data in the addon, make sure enable Roaming Data

riker_huang
Great Neighbour / Super Voisin

I use laptop to purchase the plan. The screen showed purchased successfully and a pdf receipt file shows I did purchase the roaming. But the history does not show, and the account does not deduct $20.

I purchased roaming a few times before and all work just fine. Not sure why this time failed.

HI @riker_huang   just want to be sure, on Payment history, does it has one line showing you load the money but no line showing you made the purchase of the roaming?

 

Or it has 2 lines, one about you loaded the money , and a second line about the purchase of the roaming using the $20 in your account?

mhayes
Great Neighbour / Super Voisin

Hi hTideGnow, Thanks for responding. I did do all of that with no results. A CSA has resolved the problem, however.