cancel
Showing results for 
Search instead for 
Did you mean: 

Data Not working on Unihertz Titan Pocket

Planeswalker
Great Neighbour / Super Voisin

Mobile data is not working for me on the Titan Pocket:

https://www.unihertz.com/products/titan-pocket?variant=40602974126270

I have mobile data enabled under "Mobile Network" in settings and have tried rebooting the phone.

 

I found this thread with someone else having a similar issue (don't know on which carrier) but there does not appear to be a resolution:
https://www.reddit.com/r/unihertztitanpocket/comments/qdvzq9/titan_pocket_data_problems/

 

Does anyone have suggestions on how to get this to work?

1 ACCEPTED SOLUTION

Accepted Solutions

t_p
Mayor / Maire

@Planeswalker wrote:

Mobile data is not working for me on the Titan Pocket:

https://www.unihertz.com/products/titan-pocket?variant=40602974126270

I have mobile data enabled under "Mobile Network" in settings and have tried rebooting the phone.

 

I found this thread with someone else having a similar issue (don't know on which carrier) but there does not appear to be a resolution:
https://www.reddit.com/r/unihertztitanpocket/comments/qdvzq9/titan_pocket_data_problems/

 

Does anyone have suggestions on how to get this to work?


@Planeswalker 

Do you have any data left on your plan?

Have you checked your APN settings?

Tried using 3G-only (WCDMA) ?

Tried a network settings reset?

If you have access to another phone, try swapping the SIM cards to see what happens.

 

For ref: Set up data on an Android phone (publicmobile.ca)

View solution in original post

2 REPLIES 2

t_p
Mayor / Maire

@Planeswalker wrote:

Mobile data is not working for me on the Titan Pocket:

https://www.unihertz.com/products/titan-pocket?variant=40602974126270

I have mobile data enabled under "Mobile Network" in settings and have tried rebooting the phone.

 

I found this thread with someone else having a similar issue (don't know on which carrier) but there does not appear to be a resolution:
https://www.reddit.com/r/unihertztitanpocket/comments/qdvzq9/titan_pocket_data_problems/

 

Does anyone have suggestions on how to get this to work?


@Planeswalker 

Do you have any data left on your plan?

Have you checked your APN settings?

Tried using 3G-only (WCDMA) ?

Tried a network settings reset?

If you have access to another phone, try swapping the SIM cards to see what happens.

 

For ref: Set up data on an Android phone (publicmobile.ca)

Planeswalker
Great Neighbour / Super Voisin

Figured it out. I had to enter the APN settings. I followed the instructions in this thread:
https://productioncommunity.publicmobile.ca/t5/Plans-Add-Ons/Data-not-working/m-p/507807#M65773

 

data:image/svg+xml;charset=utf8,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1 1' width='100%25' preserveAspectRatio='none'%3E%3ClinearGradient id='a' x1='0' x2='0' y1='0' y2='1'%3E %3Cstop stop-opacity=' 0 ' stop-color=' %23fff ' offset=' 0%25 '/%3E%3Cstop stop-opacity=' 0 ' stop-color=' %23fff ' offset=' 100%25 '/%3E %3C/linearGradient%3E%3Cpath fill='url(%23a)' d='M0 0h1v1H0z'/%3E%3C/svg%3E


Thanks!