cancel
Showing results for 
Search instead for 
Did you mean: 

Activating account and porting phone number

mabelmoss
Great Neighbour / Super Voisin

I want to activate an account and port my existing number. I filled in online application and it says:

"

Oops! Looks like something went wrong when activating your account.

Please start a conversation with our virtual assistant to create a troubleshooting ticket, and the next available Public Mobile Moderator can assist you in your activation via private messaging.

Note that you will need to create a Public Mobile Community Account to submit a ticket

For more information about Public Mobile support and how it works, click here

Error Code: 810

"
 
I tried to submit a ticket, but to do that I need to verify my account (using phone number, billing history etc.). But I do not have an account, and cannot get one until I have activated my SIM (which I cannot do, because I have to submit a ticket). So the situation is: cannot activate -> must send ticket -> must supply account details to send ticket -> must have phone number and be activated to set up account -> cannot activate ...
 
Can anyone help? Presumably it is possible to sign up, despite my experience today
1 ACCEPTED SOLUTION

Accepted Solutions

z10user4
Mayor / Maire

 @mabelmoss : You're in a bit of a no-mans-land (persons? 🙂 ) right now. I think I would wait a bit and then see if any charge showed up. (it could say Koodo) If nothing seems to have happened then try again after clearing cache or using a different browser or using incognito mode. . Hopefully the SIM is still able to be entered. Don't forget about leaving the old SIM in to confirm.

And hopefully you have a referral code on hand to get a $10 credit. And if you're going for a plan cost of >= $35 then try the 2GBBONUS promo code too.

View solution in original post

12 REPLIES 12

darlicious
Mayor / Maire

@mabelmoss 

The first thing you should do is see if your payment card has been charged your plan amount. If it has then you will need to contact customer support and we can help you do that.

z10user4
Mayor / Maire

 @mabelmoss : Was your payment card charged (assuming you used one)? Might your SIM actually work in a phone?

And by the way, you'll want to leave your old SIM in to confirm the port.

HALIMACS
Mayor / Maire

@mabelmoss 

 

Did you get to the payment page? 

Did you receive a port authorization request from your prior mobile provider, which you'll have to reply "YES" to in order for the port of the number to occur?

 

If so, try inserting your PM SIM card to see if you have any services.   You may wish to try rebooting device and resetting network connections.

 

You may also wish to try the live chatting option reserved for activation assistance:

Online Activation Assistance

mabelmoss
Great Neighbour / Super Voisin

Thanks for responses @HALIMACS @z10user4 @darlicious.

 

I entered payment info, but have not (yet) seen the charge on my credit card. I did not receive a port authorization request. Just pressed go on the payment page and then the error message came up. 

@mabelmoss 

Keep your old sim card in your phone to reply YES to the PAT (porting authorization text) within 90 minutes of receiving it. In the meantime contact customer support via private message since Simple--Simon is on the fritz not allowing you to verify and submit a ticket. Just follow the guideline below and put "Error during activation" in the subject line.

 

Spoiler

Here is a guideline on what to include in your private message to verify your account and speed up the service times to recieve customer support from the CSA's.

 

Send a private message...   Contact the CSA's (formerly moderators) by sending a private message and leave a detailed message explaining your issue and the info to verify your account by including the following information:  

 

  1. Full name and address on pm account. ( Or province and postal code for newer accounts.)
  2. Email, phone # and pin #.

 

If  you cannot remember your pin # include at least three ( if they apply)of the following:

 

  1.  Date of birth (n/a on newer accounts.)
  2. Last payment, date, amount, type and last 4 digits.
  3. Alternate phone number if any.
  4. Security question and answer.
  5. Plan amount, any add ons or promos on account.
  6. Last 4 digits of sim card.
  7. Any rewards in your account.
  8. Autopay y/n?
  9. Account #.
  10. Frequently called/texted phone numbers in the last 30 days.  

 

The average wait time is 2 to 4 hours but be prepared to wait up to 48 hours for non urgent requests. Current wait times are about one hour and are probably even less if you are able to supply all of the necessary info to avoid having to verify again via a link or text message sent to you by the CSA. 

 

Hopefully pm fixes this glitch sooner than later and cranks out an official announcement that the fix is in!! Be sure to choose an appropriate heading for the Subject Line that summarizes your issue.

 

Keep an eye on your private message box the envelope icon next to your avatar for a little number to pop indicating a message from the CSA's (formerly moderators.) Responding promptly will speed up service times.

 

 Do not post any of this info in the community only in your private messages when communicating or contacting the CSA/Moderator_Team.

 

  To send a private message to the CSA's (formerly moderators) click below
https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

z10user4
Mayor / Maire

 @mabelmoss : You're in a bit of a no-mans-land (persons? 🙂 ) right now. I think I would wait a bit and then see if any charge showed up. (it could say Koodo) If nothing seems to have happened then try again after clearing cache or using a different browser or using incognito mode. . Hopefully the SIM is still able to be entered. Don't forget about leaving the old SIM in to confirm.

And hopefully you have a referral code on hand to get a $10 credit. And if you're going for a plan cost of >= $35 then try the 2GBBONUS promo code too.

Anonymous
Not applicable

@mabelmoss 

i suggest you close all Browser and do clear cache and cookies for any Browser,

and try open one Browser incognito mode,

or try it for a different Browser and open incognito mode,

how to open Browser incognito mode visit Here link,

how to clear cache and cookies and History visit Here link,

and use a Browser from your computer,is better

use Browser microsoft edge or chrome latest version
and just make sure your Browser is up to date update
sometime is the Browser is not update is give a issue.

how to update your Browser visit Here link, 

and Restart your computer, is will help a lot,

 

if you can't fix it you need to Contact Customer Support Agent by CS_Agentand Explain your issue to them can solve, they are nice service Team the will help you 100%.

 

Here’s How To Contact Customer Support Agent

  • send a private message to Customer Support Agent by Click Here link,
  • please include in your message,
  • phone number,
  • Email address,

 

  • Customer Support Agent by CS_Agent, will Response to your inbox by private message 
  • During business hours, we strive to answer customer messages swiftly. You will often get an answer within an hour. During peak periods, you may need to wait up to 48 hours.Customer Support Agents are available:
    • Monday to Sunday: 6 AM to 10 PM EST
    • Note: Public Mobile No Support by phone call or Email.. only by CS_Agentprivate message..

    Check your private message inbox (click on the envelope top right of your screen)

         Good Luck..

mabelmoss
Great Neighbour / Super Voisin

Thank you all for your help - much appreciated. Turned out it was a problem with using Chrome. I used Firefox incognito mode and it seems to have worked. Silly me trusting google

darlicious
Mayor / Maire

@mabelmoss 

Woohoo! Welcome to public mobile! Well now at least you know how to contact customer support via private message while Simple--Simon is on the short circuit circus ride to silly land.