cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Great Neighbour / Super Voisin

Sim not working ??

Hi, so i just set up my new pm SIM card and plan, used a  voucher for payment, picked a new phone number, set up an online account , went through the whole transaction/ process and at the very end it said i was all set up and good to go .

Not so much the case, my phone [an unlocked Galaxy S6 Edge] says that yes theres a pm SIM in it but will not register on the network. Ive tried adding new apn from a different thread i had seen posted on here , still no luck. Nor can i seem to login with the online account i made and when i go through to the forgot password it tells me a website link ending in "invaliduser"?? 

I have no idea what obviously went wrong so please help me put here thank you 

Mayor / Maire

Re: Sim not working ??


@corrchern27 wrote:

Hi, so i just set up my new pm SIM card and plan, used a  voucher for payment, picked a new phone number, set up an online account , went through the whole transaction/ process and at the very end it said i was all set up and good to go .

Not so much the case, my phone [an unlocked Galaxy S6 Edge] says that yes theres a pm SIM in it but will not register on the network. Ive tried adding new apn from a different thread i had seen posted on here , still no luck. Nor can i seem to login with the online account i made and when i go through to the forgot password it tells me a website link ending in "invaliduser"?? 

I have no idea what obviously went wrong so please help me put here thank you 


@corrchern27  Do you have access to another phone to test your sim card? If it's still an issue best to notify PM.

 

To contact Public Mobile click here. The link  sends you to the private message function and adds the moderator team as recipient for a private message. You just have to enter a title and text in the body of the message describing the problem and post. The message will be received by the moderator team and they will respond to it. You will receive the response in your private message inbox.

Moderators are available: M-F from 8 AM to midnight Eastern time and S-S from 8 AM to 10 PM Eastern time.

Note: Moderator Hours are subject to change, but you can always find the current times here

Please note that account verification may be required when contacting the Moderator Team 

 

Oracle

Re: Sim not working ??

@corrchern27 , typically receipt of the welcome email is a good inductor that the setup is complete.  Since you are unable to login to the self serve and cannot connect to the network, I think there is no much more troubleshooting that you can do yourself.  I suggest getting help from the moderator team.  The moderator team can be reached via private message using this link.  Please include a detailed description of the issue and the required resolution. This will speed up problem resolution significantly. Refer to the following knowledge base link for additional information on contacting the moderator team.

Great Neighbour / Super Voisin

Re: Sim not working ??

I have tried it in 4 phones all of which do the exact same thing

Mayor / Maire

Re: Sim not working ??

Try using another browser and incognitio mode.  Also clear your cache.

Highlighted
Deputy Mayor / Adjoint au Maire

Re: Sim not working ??

Hi

You will have to create account with the same email that you use at sign up.

Do you have access to a different unlocked phone, could you borrow one from a friend, preferably that works ok on telus network

If that doesn't work you may have to contact support at https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

Mayor / Maire

Re: Sim not working ??


@corrchern27 wrote:

I have tried it in 4 phones all of which do the exact same thing

 

@corrchern27  If that is the case you definitely need to message the moderators to fix your account.


 

Oracle

Re: Sim not working ??


@corrchern27 wrote:

Hi, so i just set up my new pm SIM card and plan, used a  voucher for payment, picked a new phone number, set up an online account , went through the whole transaction/ process and at the very end it said i was all set up and good to go .

Not so much the case, my phone [an unlocked Galaxy S6 Edge] says that yes theres a pm SIM in it but will not register on the network. Ive tried adding new apn from a different thread i had seen posted on here , still no luck. Nor can i seem to login with the online account i made and when i go through to the forgot password it tells me a website link ending in "invaliduser"?? 

I have no idea what obviously went wrong so please help me put here thank you 


@corrchern27  great and infomative post.

 

APN only affect data.  have you tried a manual network search?  

 

if the forgot password gives you an inavlid user you probably encountered an activation error.  did you receive an email form PM by chance, it should send an email on activation.  or is there anyway you entered a different email during activaion?

 

have you tried the activation process again with the same sim # (does it give you invalid sim number?, trying to see if activation process went through, if it doesnt give invalid number your activation was not succcessful).  

 

IF activation error is the issue you will need to write a private message to moderator_team  also include your sim number,  and if you can a screenshot of recent transactions from your credit card.   and possibly useful approximate time and date of activation.  make sure they understand it was an activation error and that you have no service on your sim and no selfserve account. 

ofs
Good Citizen / Bon Citoyen

Re: Sim not working ??

If you have tried all the options suggested in this forum already, other common issues (experience from working at a mobility company) could be...

 

1) Check if the sim card is put upside down. 

2) Is the sim card activated?

3) Double check the sim card number and see if it is entered correctly for activation.