cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

Need help activation went bad

So two days ago I went to a retailer to start a plan and switch my phone number over an when we went to do that it didn't go through and the sim card said sim  emergency calls only and the retailer talk to someone at public mobile and they gave me a temporary phone number and that did still not work. After we a few hours we tried to port my number over again and this time it got stuck in limbo so I had to call my previous carrier to get it switch back over. So now still don't have a working public mobile sim and I have paid for a $35 plan. Than I pm the moderator team last night and still haven't heard anything from them . After that i Iost access to my self serve account and it keeps saying failed to log in even though I'm using the same password and account information as before I just want to get a hold of someone in the company that can fix this or give me a refund or something because I think I was better off sticking to my old Carrier 

Highlighted
Mayor / Maire

Re: Need help activation went bad

@Andrew55 Try accessing your account using the Chrome browser in incognito mode. If you still can't get in send a message to the moderators to get access.

The moderators are currently very busy so it may take a couple of days for them to respond. Smiley Frustrated

Highlighted
Great Neighbour / Super Voisin

Re: Need help activation went bad

agree with Alex try a different browser that usualy helps.

Highlighted
Good Citizen / Bon Citoyen

Re: Need help activation went bad

Ok sounds good I guess I'll play the waiting game and no luck to the using the incognito Page still giving me the same error

Highlighted
Model Citizen / Citoyen Modèle

Re: Need help activation went bad

Perhaps the "retailer" ( in my case I had to direct the Walmart clerk) made a mistake when filling out the form - Why don't you start fresh and carefully re-try filling out  the form. 

Highlighted
Oracle

Re: Need help activation went bad

@Andrew55, you seem to have many problems with your account, so moderator team assistance seems unavoidable.  If you have contacted them already, then the only thing left to do is wait patiently.  Given the high volume of new activations in recent days and possible issues with new account set up, moderator team workload is likely very high.  Stay patient, good things come to those who wait.  BTW, you mentioned getting a $35 plan.  You may want to take a look at this $25 plan that was recently released.  It might suit your needs and provide a good savings every month. 

 

https://www.publicmobile.ca/en/on/plans/25for500MB-3Gspeed

Highlighted
Mayor / Maire

Re: Need help activation went bad

@Andrew55, are you sure your phone is unlocked, or locked to Koodo or Telus?  What was your previous provider?

 

You can't just start over, as you've activated a plan, however, you haven't received the text message to get it going.

 

If you haven't unlocked or phone (or it's not from Telus/Koodo), you will need to get it unlocked by the previous provider.  At that point, you should be able to insert the SIM and have a working connection.

 

If the phone did come from Telus or Koodo, you'll need to contact the Moderator_Team, via private message.  You can do that with the envelope icon in the upper right corner of this webpage.

Highlighted
Good Citizen / Bon Citoyen

Re: Need help activation went bad

@@will13am yeah I'd figured as much as that also I did see the $25 plan was gonna try that but you get a little more data I think from the $35 plan was gonna slowly but less data as my last plan was a 8gb family plan so im gonna need to adjust to it lol also @stonechucker the phone was with Telus and than I got it unlocked before I tired to switch just in case and thanks everyone for the help 

Highlighted
Good Citizen / Bon Citoyen

Re: Need help activation went bad

@Beer I'm wondering if that could be the issue but how would you redo the form with out making a new account since I already paid for it also I still can log into my account

Highlighted
Model Citizen / Citoyen Modèle

Re: Need help activation went bad

If you have an account and are able to access it then carefully review all your settings. Also look that your account is active and the lost/stolen feature is not activated.

Under OVERVIEW - you should see "Account Status: Active"