cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Great Neighbour / Super Voisin

Horrible customer service

My plan stopped working after a renewal and plan switch. Getting "you do not have a long distance add-on" when trying to make a call. I contacted the Moderator three days ago, then followed up a day ago. Complete silence. Full ignore. There is no other way of getting support other than via the Community Forum moderator. Three days with no service and no reply from the provider - what is that??? Public Mobile treats its costumers like dirt. It's like: we are [slightly] cheaper than the others, so suck it up and don't whine. Frustrating...

Re: Horrible customer service

@SergeMaslov, you are the second subscriber whose first post is complaining about sending in a private message an not get a response for 3 (or more) days.

 

The community is very well versed in these things, and if there's a chance we can assist, if you ask and provide your issues and relevant screenshots on day 1, we potentially have the ability to assist you.

 

Moderators respond on a first in, first out, basis.  No one issue is more important that another.  Current response times are 72+, so let's find out how we might be able to assist.

 

And by the way, I'm saving more than double what I was paying to Rogers, and getting more now with Public mobile.

 

 

Great Neighbour / Super Voisin

Re: Horrible customer service

Does it matter if it is my first message or 100th? Do I have to earn a solid reputation in order to get a proper customer service? I understand that it is first come first served. However, different customers might have different issues. When one paid for a term (a month) but not receiving the service for a portion of the term, I believe, it should become a higher priority. Otherwise, the provider is simply stealing my money.

Here are the details. When trying to make a call I am getting a voice message "Sorry, we cannot complete your call. You don't have an active long distance add-on." I recently renewed my plan. It used to be a $20 plan, but I changed it to $10 for the next month. I had a balance of $10 on my account, and the entire amount got deducted once I renewed the plan just as expected. Now it shows the plan as Active and $0 balance, and the next renewal date as November 23, but I still have no service. Something likely went wrong during the plan renewal/switch. Sorry, no screenshots; I don't think there are any relevant.

Thank you.

Model Citizen / Citoyen Modèle

Re: Horrible customer service

lol ya what ur saying is true, but alot of problems can b avoided with quick searches, i imagine you got a unique problem so hopefully it could get recrified

Moderator

Re: Horrible customer service

Hello @SergeMaslov and anyone who shares this same concern,

 

I understand your frustrations in regards to the wait time, but during peak season, we do have a delay of 24-48 hours.

 

I know some of you have mentioned waiting longer than this, but please note that when you send us multiple messages, this pushes you further in the wait line, as our system will take into consideration your most recent message.

 

We value helping each and every one of you on this Community, but in order to do so, it is best if we work together. Simply send us one message with the required information and we will do our best to get to your request in a timely manner.

 

Also, as you may have noticed, we have great Oracles and Community Users who can help you Smiley Happy

 

That being said, we truly appreciate your cooperation, patience and understanding, as we work through all your requests.

 

Best regards,

Ashley

Oracle

Re: Horrible customer service

@Moderator_Team can you please confirm your statement about resetting the queue. This is opposite of what @Mary_M clarified a month or so back.

 

Thanks

Mayor / Maire

Re: Horrible customer service


@SergeMaslov wrote:

Does it matter if it is my first message or 100th? Do I have to earn a solid reputation in order to get a proper customer service? I understand that it is first come first served. However, different customers might have different issues. When one paid for a term (a month) but not receiving the service for a portion of the term, I believe, it should become a higher priority. Otherwise, the provider is simply stealing my money.

Here are the details. When trying to make a call I am getting a voice message "Sorry, we cannot complete your call. You don't have an active long distance add-on." I recently renewed my plan. It used to be a $20 plan, but I changed it to $10 for the next month. I had a balance of $10 on my account, and the entire amount got deducted once I renewed the plan just as expected. Now it shows the plan as Active and $0 balance, and the next renewal date as November 23, but I still have no service. Something likely went wrong during the plan renewal/switch. Sorry, no screenshots; I don't think there are any relevant.

Thank you.


There is no prioritizing of requests. That would become a gong show of my story is more dire than yours...get out of my way. Not how it works here. But ok you're expressing your opinion. We all have opinions. I think the response time here is terrible too. But I've had zero problems here since joining in May. Couldn't be happier saving a bunch of money.

 

So you're on the $10 plan and it says active.

Did you restart the phone?

Can you try the lost/stolen trick?

Can you try the add another $1 trick?

Can you try the SIM in another phone?

Great Neighbour / Super Voisin

Re: Horrible customer service

Yes, my account status is Active.

I have restarted the phone.

The cellular network it is connected to is "Public Mobile".

I added $2 to my account. It charged me $2.24, and my current balance is $2.

I still have to service. Same stupid message.

No, I have not tried the lost/stolen trick. Neither I tried the SIM in a different phone. Will try both later, but I greatly doubt it that it would help.

Good Citizen / Bon Citoyen

Re: Horrible customer service

I set up my phone 2 WEEKS AGO & I have NO SERVICE at all. I'm so pissed. I want a refund as I can't even get a reply to my questions.

Highlighted
Oracle

Re: Horrible customer service


@ArleneMacIsaac wrote:

I set up my phone 2 WEEKS AGO & I have NO SERVICE at all. I'm so pissed. I want a refund as I can't even get a reply to my questions.


If you have sent your requests here: message to moderators then you done everything possible.

Meanwhile, if you need to make phone calls try an application like that from fongo.com. It provides free calling across Canada from wherever you are connected to wifi (or on cellular data). Even though I have never needed it in 4 years, it's my backup service for these situations.


>>> ALERT: I AM NOT A MODERATOR. JE NE SUIS PAS MODERATEUR.